Select by attribute value - don't accept space as character in command line

if value is blablablabla you cannot select objects with this value because command line just jump to next them as soon as you press space

fwiw, this attribute value does not have spaces… :°

Anyway, when you need to input something with spaces, enclose with double-quotes.

An object that has an attribute user text with key some key you would select with: SelKey, then enter "some key"

there was space between blabla blabla :d anyways thanks for this hack

This is generally true when sending text containing spaces to the command line. Space bar = Enter in Rhino if there are no quotes; that is how all macros work for instance.


I was trying to find some good info on that {double-quote vs no double-quote} + space, but the documentation doesn’t tell that explicitly. Maybe this should be added in a clear and explicit way at least on this page|_____1

The mention of quote marks in the section on ReadCommandFile is too far away from the section “Writing Command Macros” at the top, where in the second sentence space is mentioned to function as Enter. It is here that the double-quote should be mentioned.

Logged as issue: RH-61224 Tell how to handle options and input with space on the command line