Script editor issues

Hi,

indentation :

I don’t understand the way white spaces are managed.
I can show them, I can convert them but I’m never sure when a new indentation
will be spaces or tabs.
Is it possible to have an option which forces all new indent length and indent white spaces type ?

find & replace

It does not seem to work. It finds all occurrences. It lists them in search panel.
But I have to scroll manually to find them in the code.

Regards

@lahos

  • Indentation generally follows whatever that is in the script. So if your indents are spaces, hitting Tab in a new line will insert spaces or vice versa. Let me know if it does not work like that for you

  • We have put a good amount of cleanups on search and replace in 8.9 SRC which will come out soon. I would appreciate if you can give it a try…

Thanks for reporting these bugs :smiley:

Hi,

Indentation

Not working completely.
When I am in “tab mode”, not space, if I press return at the end of an indented line, the resulting new line indentation is made of spaces.

[tab][tab]amazing code(pressed return here)
(auto indentation made of spaces)

Pressing tab to indent seems to change the focus to the Find & replace panel… I have to close it to make coding possible.

Where can I specified the number of spaces use by a single indentation ?

Find & replace

I tried 8.9 but crashed as soon as I pressed F3.
I am not sure about searching all files by default. I have at least 5 files opened all the time. Having to parse all the results of all files is not gonna make me using it.
Maybe a checkbox to apply search to all files or only the active one… Or to collapse all inactive files results.

Regards.

I just retried the editor and it does not detect the indention style of the file.
Sometimes it does…

Regards

1 Like

Ok. So I tested two scenarios:

  • Open a new script and run Edit > Convert Indentation to Tabs. This puts the editor in so called “tab mode”. All the TAB key presses will place tabs.

  • Open a new script and run Edit > Convert Indentation to Spaces. This puts the editor in so called “tab mode”. All the TAB key presses will place 4 spaces.

Is this the behaviour on your machine?

It would be great if you can list of set of steps that I can just replicate to see where editor places spaces where it should place tabs

The first 8.9 SRC is out today so it would be great if you can test that

Hi,

(Using 8.9 RC)

What can I say about reproducing the bug…
I open a python file (or select an already opened one) containing only tabs and the first indent I create is 4 spaces…
When I use the [Convert Indentation to Tabs] it seems to work.
But I don’t want to do that for every file.
It was my point when I asked to have an option to force the style.
Personally, I just want tabs and don’t have to think about it.

(by the way I can’t open text file like .ini like in the genuine script editor… normal ?)

Find & replace

It seems to works well now. It even has the “all files or not” button. thanks!

Regards

  • new test :
    create a new python 3 file
    #! python3 is already at line 1
    add a tab at line 2
    save the file
    reopen the file
    press tab after the existing one (line 2)
  • expected result:
    2 tabs at line 2
  • result :
    the existing tab is converted with 4 spaces.

@eirannejad ,
I create an issue for this

2 Likes