Screen Glitch Error

Ever since I’ve updated my Rhino 6, I have been experiencing glitch on my UI screen.
It appears quite frequently. I don’t know how I should fix this.
I’m working on my Windows 10 and this glitch shows up even with small file.

I checked if it has to do this my memory. But Windows Memory Diagnosis shows no error.
Does anyone else having a similar issue?

Can you run SystemInfo in Rhino and copy/paste the results here?

Rhino 6 SR26 2020-5-26 (Rhino 6, 6.26.20147.06511, Git hash:master @ 7788f6214ee9335d5793cc6177985a1c745e663b)
License type: 商用版, build 2020-05-26
License details: Cloud Zoo. In use by: [deleted]

Windows 10.0 SR0.0 or greater (Physical RAM: 32Gb)
Machine name: [deleted]

Hybrid graphics system.
Primary display: Intel® UHD Graphics 620 (Intel) Memory: 1GB, Driver date: 8-23-2019 (M-D-Y).
Primary OpenGL: AMD Radeon Pro WX3200 Graphics (AMD) Memory: 4GB, Driver date: 4-15-2019 (M-D-Y). OpenGL Ver: 4.6.13559 Compatibility Profile Context FireGL 26.20.11002.1001

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: ATI Technologies Inc.
Render version: 4.6
Shading Language: 4.60
Driver Date: 4-15-2019
Driver Version: 26.20.11002.1001
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 4 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.26.20147.6511
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.26.20147.6511
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.26.20147.6511
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.26.20147.6511
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

@Helvetosaur Thank you for your reply. Here’s SystemInfo. I’ve deleted my account name and machine name.
I’ve downloaded the recent version of Rhino 6 for Windows from Rhino website and tried “repair” but that did not help as well.
Any help is appreciated.

Your video card drivers are a bit out of date, first thing to try is updating them.

Sorry for the late reply. Updating old video card drivers solved the glitch problem.
Took me sometime to respond since control panel - device manager showed that my video card driver is up-to date.
I had to find the most recent release from the AMD homepage.
Again thank you for your help.