Scaling SBSAR materials accurately for Cycles render

I’ve been playing with a Substance material that requires me to scale my surfaces significantly on the UV map. I’ve been judging this by eye, but that begs the question: if I need the material to be scaled to a precise size, or consistently across multiple objects, how best to go about it?

TIA
Jeremy

can you post a material and file to show what you are doing? If not the specific file, an example perhaps?

Hi @theoutside,


Here is an example. I have some lengths of rope. The loose ones are supposedly from the reel so the flecks should repeat at consistent distances. If I just apply the material directly it is way out of scale, as shown in the short loop. I can scale it on the UV map by eye, but I probably won’t get the same repeat (as shown by the straighter length having a different repeat from the coil).

What’s a good workflow for being consistent or, better yet, being able to set a repeat at 40mm for all objects?

Discourse won’t let me upload the file - can I mail it to you?

Regards
Jeremy

You can always upload to rhino3d.com/upload and copy the URL to this thread in the comments section. It’ll end up on Kyle’s list eventually (:

Thanks @nathanletwory, I’ve done that.

1 Like

You hear that @theoutside? You’ll be getting mail!

got it, it’s repeats in the texture mapping of the object- Make more to scale the texture-

OK so, for the loop, I set the repeats to 26, texture looks hunky dory. But wait, I don’t like the ends, they have the same braided texture as the side. So I open the UV map and scale the ends up to see if I can cheat my way out. Accept the change and now texture on the side has compressed even though I did nothing to it in the edit. Let’s change the 26 repeats to one repeat - eureka the texture is back to where I wanted it.

So it looks like there is no permanent relationship between the repeats setting and the texture repeat on the surface. That is very confusing. Seems like a bug to me.

So, to return to the original question:

I set the repeat for the loop to 26, but if I apply that to the longer, straighter piece then my repeat is longer (no surprise as the piece is longer). I actually need to set it to something like 34.

So is there no way to set the repeat distance instead of setting the repeat count? That would be much more user friendly if you want to get the same size repeat on different size objects.

Jeremy,

I'm following your thread here and just wanted to show how your material mapped to Steve1's lanyard.

On re-opening the model next day, the material goes back to being too big and I need to reinstate the 26 repeats. C’mon Rhino, play nice.