Scaling of a Nurb by Nurb

Hey there!
This is my first post on this forum, because I’m looking for a smart way to solve the problem I’m having atm.
My problem is: I have 2 nurbs which started from the same basic icosahedron. After 2 months of work, by different people, in different files, they are no longer the same size. I need to scale them back to the same size (because those Nurbs are modules which are going to be used in the grasshopper plugin Wasp to run an aggregation.) Is there a way to do this 100% exact?
In a lot of CAD programs it is possible to do scaleing of an importet file by first picking 2 points in the imported file and then another 2 points in the existing file (so we have 2 different lenghts) to automatically scale the imported file. (Rhino-scaleing sadly doesn’t work like this?)
I hope this is understandable. For further explanation I have attached a Jpg of the 2 modules and a Rhino-file containing the 2 mentioned modules.

Thanks in advance!

Icosahedron.3dm (844.0 KB)

Try Orient3Pt with Scale=Yes

Thank you both for your quick responses on my question! “Orient3pt” first and “scale” second worked!

I’m just curious if you could answer me another question that came up working with “Orient3Pt”.
When selecting an object and picking the reference points, it is annoying as hell to always see every edge/curve of the object at once. Is there a way to automatically hide the edges that should be obstructed by surfaces?
I found an option to switch off displaying the Isocurves, but nothing else. :unamused:
I would really appreciate if you’ve got also an answer to this. :+1:t2:

There is no need to use Scale after Orient3Pt If you use the option Scale=Yes in Orient3Pt.

Orient3Pt has no Scale parameter in V5, only in V6

Only the simple “orient” offers a scale option in Rhino 5.
I double-checked it.
Still any idea on how to hide the unnecessary edges/curves wenn selecting an object? It’s very annoying when I want to pick a knot and it jumps to a close knot on the back of the module. :face_with_raised_eyebrow:

As far i know, there is no possibilities to tweak selection displaying lines, but i agree, it’s really annoying, an option to show only visible line according camera orientation is really necessary in my opinion.

Yep, but that not working when objects are selected, and that the problem.

Edit : ok i found option in settings, good to know.
Edit 2 : also work with meshes , thanks Richard, you make my day.

Thank you for your solution!:+1:t2:
I was already looking into preferences of the display modes, but only for “shaded” and somehow their is no option like in “technical” to switch of “show hidden lines”. :roll_eyes: Not every display mode gives the same options. Kind of confusing…

I’d say that everybody gets confused by this. And it doesn’t really get better in RH6.

The short version is that the options depend on which display pipeline is used. Technical uses the Technical2D pipeline and doesn’t expose a setting to change (or view) this. Most other display modes use the OpenGL pipeline.

It starts getting confusing when you copy display modes. A copy of a Technical2D based mode will set the pipeline to OpenGL without you being able to switch this to Technical2D.

The (e.g.) default “Shaded” display mode is set to OpenGL without you being able to change that. A copy thereof, though, will allow you to change this to either Technical2D or Windows.

Hmmm… perhaps the latter is only possible when you import a display mode from Rhino 5? :confused:

No, but as technical have Shade objects options , that can do the trick no ? at least for shade mode.

Just to let you know: There is a way to achieve what we were talking about in every view-mode.
Just tick the boxes of the options I marked and shaded surfaces will cover the curves in the background.