Scaling dialog when runscript

If run the below script, the scaleing dialog pop up, any way to suppress it? Thanks!

-_Export all Enter D:\images\An-28scaled.iges Default UnitSystem=Millimeters Tolerance=0.001 Enter Enter

Another question, if we run the script in Chinese version RhinoApp, or france version RhinoApp. The text for RunScript is still the same? which means all english. Thanks a lot.


Hi @Robin3,

Definitely a bug.

Use the underscore, or “_”, character in your scripts.

– Dale

Got it, Thanks Dale!

Just a check, had the bug be fixed, if so, where we can download the latest igest export plugin then, Thanks a lot!

Hi Robin -

The bug was fixed on June 23rd.

It appears that the fix went into Rhino 8. Generally, at this point in the development cycle, only severe crashes and regressions are fixed in Rhino 7.

Thanks Wim, let me check if we can fix it on our side then, Thanks a lot!

Even, the document unit is inches, and I call
“_-Export _all _Enter “D:\test\test.iges” _Enter _UnitSystem=Inches _Enter _Enter”, the dialog still pop-up, any way that we can bypass it in Rhino 7.0.

Or we can go to the setting file or setting data, to force the iges units match with the document unit, if so, any API to get the Iges export settings?

And we need it ASAP, our release close is today, Great thanks!!!

Sine it seems the codes are in Iges Export plug-in, is it possible that we can get a fixed iges export plug-in dll, so, we can provide to the Rhino 7.0 user, Great thanks!

Please ignore the requests, my scripts is wrong, set the units in the script will bypass it, Thanks a lot!!!