Scale to zero in rhino

Why i can’t scale to zero using 1d scale in rhino ?
whenever i scale an object using scale1d whet i try to scale it to zero (back to the starting point) the model jumps back into it’s normal scale.
what kind of logic was behind this ? Im really confused right now .
ezgif-4-3db6d24e59

What do you mean scale to zero? Squashing a solid flat or a surface into a line would be bad geometry.

2 Likes

What exactly do you mean with getting the object back to the starting point? What are you trying to do? Maybe there are other ways of achieving what you want to do.

1 Like

I uploaded i gif file to describe it a little more , i know that i can do a lot of work around , but it’s not straight forward .

Would it be possible to use numerical input set at zero instead of dragging it to the 0,0,0 point?

1 Like

0.000000001 works but 0 doesn’t

I see, with the scale command it doesn’t work. But maybe the move command can achieve what you’re after? The only issue would become that there are then two points on the exact same place.

To fix that I advise to pull the top point onto the bottom point, select both and use the command WeldVertices. This gets rid of the double vertices.

2 Likes

Sir , i really can achieve this by a lot of many other commands , but this is really bothering me why or what kind of logic was behind this ? to not to let the user to scale something to zero , after rhino 7 it is possible to achieve this with gumball which is limited by it self . do mcneel put this into the software on purpose ?

Okay we still don’t know what you’re trying to do or why, or why it’s such a big deal to you. Scaling objects to a dimension of 0 is, not all the the time but generally, going to give you screwed-up geometry. That’s it. It’s an issue that has literally never been a problem for me in over 20 years using the product.

…Oh I see your gif. Yes you’re squashing points onto each other, which is bad geometry. Are there other commands that let you do this? Sure, but then again, congregations you’ve just broken your model.

i agree with @hamed.desighn it would be great to have 0 as scale factor.
also from a intellectual point of view.

a workarround for the scale1d - factor 0 (for control points):
_setPt
(maybe combined with a custom cplane)

1 Like

Some rhino users be like : ok lets use ProjectToCplane command and not to simply scale the curve or what ever it is to zero (also it doesn’t matter what im gonna do , what is matter is that this is an obvious BUG inside this software my friend :slight_smile: )

Yeah, I do not see why this should not work. I’ll get it on the pile.
RH-67702 Scale1D: accept zero

-Pascal

5 Likes

I mentioned that earlier thanks , poor win 7 users who use rhino 6 won’t have it

Shouldn’t make chat here i guess , not me , but some companies who don’t want to get attacked by virus will use win7 also disconnect their pc from the rest of the world.

workarounds include:
setting the gumball to a location and scale zero.

Or use setpt in the z (in this case)

they both do the same thing.

however, to your point this should work.

3 Likes

Yeah and? It’s not exactly something that justifies a retroactive fix.

Is he just using the wrong command?
Is he trying to set the Z to Zero?
SetPt?

1 Like

@John_Brock sir i think that you just don’t get it , i already know that there are many commands that can do this , but using another command for same task is not just straight forward and is a bug

Clearly, I don’t.

1 Like

I don’t understand how such scaling would be mathematically possible.

What would you divide the number 10 for it to become zero?

What would you multiply the number 0 for it to become 10 again ?

2 Likes