Scale NU z factor

i moved crv in series in z direction (step 5, count 71) to create floors. i also need the structure for which i used the braced grid 2d and loft a polygone through the lines but here comes the problem: when i put a graph mapper on the floors to to scale it with scale NU in x and y direction without touching the z direction it still scales in z direction and then the nodes of the structure do not fit. can you guys help me please i am struggling till two days and i cannot solve it

scaling with graphmapper

without scaling

Without seeing the file, all I can surmise is that there’s a value inside the Z parameter of Scale NU which is not 1.0. The default value is 1.0, so either it was changed or there’s something else going on.

If you can internalise the relevant data (just the curves going into the Scale NU and the numbers going into the Graph Mappers). See point #3 here on how to do that.

fassade test (38.8 KB)

those are the files… i work a little bit messy sorry for that

That’s why I asked whether you could cut out 99% of the file and only post those bits that don’t work. You can remove all components to the left of some parameter by internalising the data inside that parameter (see link in previous answer).

Also the file as posted requires the Weaverbird, MeshEdit Components and LunchBox plugins. If you remove the components that do not matter for this question I can open the file without having to install them first.