Saving Failure

I reported RH-63427 to keep track of this issue.

Hi Pascal, sorry for disappearing, I haven’t been getting any notifications for some reason. To answer your question, I was just talking about my desktop vs laptop computer. It sounds like you have it pretty much figured out. I can confirm that I too had installed Hops and there is every possibility that it was my issue as well. I hadn’t gotten a chance to dig into it yet so when I re-installed everything it wasn’t on my need to have plug-in list. There have been no further occurances of this error on my re-install so all is well on my end.


The issue with Hops is fixed now. Just get version 0.4.6 or newer from the Package Manager in Rhino.

RH-63324]( is fixed in the latest Rhino 7 Service Release Candidate

The issue related to “Saving to Network drive” failure seems not to be solved, even in the Service Release Candidate installed today.

Any news? @stevebaer ? @piac ? @brian ?

That’s strange. I made the default option for WriteLocalTempFileWhenSaving to false because we couldn’t determine the cause of the saving failure on your network. Is this value set to false on your Rhino? It should be false for you.

Yes yes it is!
And everything works with the NEW default setting.

Just a misunderstanding: I would mean “did you solve the issue with the option set to TRUE”?
I tried to set it TRUE on my own: it was actually pre-set to FALSE!

Help me make sure I understand exactly what you are seeing

  • Does file saving on your network work with WriteLocalTempFileWhenSaving = False?
  • Does file saving on your network work with WriteLocalTempFileWhenSaving = True?

It is set to FALSE.

I tried to force it back to true, to understand if the problem behind this strange behaviour (when set to true) was solved.

No modifications have been made to Rhino for this yet. I would like to understand why this setting does not work on your network as it would be good to have this feature turned on by default.

Right now I am trying to figure out if we can add some code to help determine exactly where in Rhino this setting is causing a failure to save. I will reach out to you when I have something that you can test.


@stevebaer, is there anything I can do to help you find this bug? Manually changing names to record saves, or updating linked references is not a pretty task to manage by hand.

I currently experience the same issues (frequently cannot save to a server) and it completely blows apart a workflow using VisualARQ where I must reference geometry as embedded and linked blocks.

Maybe @fsalla is also interested because in one test, saving was successful until I loaded Tibidabo, then I immediately got the ‘cannot rename tmp file’ error.

Rhino 7 SR7 2021-6-9 (Rhino 7, 7.7.21160.05001, Git hash:master @ d2161989109d5dacba531310b5d345ce6f4da9f6)

Are you referring to the issue where WriteLocalTempFileWhenSaving = true is not working for Gianpietro?

@gian do you have Tibidabo installed like Kevin3 does?

Hi @stevebaer .

Nope: no Tibidabo here.

Yes. WriteLocalTempFileWhenSaving cannot be turned to false, and is consistently interfering with saves.

Does WriteLocalTempFileWhenSaving=true work? That would be the preferred setting to use and is only set to false because I need to figure out why it fails on Gianpietro’s network.

I would say no, WriteLocalTempFileWhenSaving=true does not work.
I frequently (2-3 times daily) have trouble saving to the network because the tmp ‘file name cannot be changed’ (or something similar; I cannot confirm at this moment). If …=true were working, it would try to write locally, correct?

I tried to set WriteLocalTempFileWhenSaving=false, but I did not restart Rhino therefore I suspect is why …=false did not work.

By the way, no news on that side?
Am I the only one facing this issue?

Thanks for your work, anyways!



In my case it does work.

Hi @gian
You are the only person I know that is facing this issue, but there is a good chance there are many users out there who would also experience this issue and not report the problem to us.

I added some code to try and diagnose the cause of the problem that we can try now with the latest 7.8 release candidate. Here’s what you can do to help test.

  • Get the latest 7.8 release candidate from last week.
  • Change WriteLocalTempFileWhenSaving to true and validate that you can’t save to your network drive
  • After the file fails to save, run the test command TestLocalTempWriteDebug. If I was able to detect the error, I try to write a message to the command line. Please let me know what the command line says after you run this command. Even if it says “no error detected” that gives me a clue I’m looking in the wrong place.