-_SaveRenderWindowas not saving alpha channel

-_SaveRenderWindowas is not saving the alpha channel when using the command from a script or the animation tools like flyover or turntable.
If I save the file manually as a png the alpha is preserved if I use the -_SaveRenderWindowas command and script a file location the setting alpha setting is not used.
In fact there might need to be a setting for that or is this broke?

Could I please get a confirmation from McNeel that this is broken or not, I can’t get this to work I waited a week for McNeel to answer and nothing. I need to get these frames out as png files asap.
Thanks for any info on this.

Hi RM - sorry for the delay - as far as I can see at the moment this is indeed broken…


Thanks Pascal. Any ideas of when this might get fixed?

Also I think the alpha setting should be a switch at the command line in the saverenderwindow as command, because it would make the command more complete and we would not have this extra weird setting dangling out there. It’s the only setting on the render window that has a checkbox when .png is used.

I know it’s file specific in this case but this setting is a mess in general. It’s in three or maybe four places too. Like in options, in render panel and in the check box of the saved image.
Something needs to be done there.

RH-47252 is fixed in the latest Service Release Candidate