SaveAs PDF does not open in Acrobat Automatically


(Luis Fraguada) #1

Hello,
I’d like to NOT have the resulting PDF opened after I print it. Is this possible?

Luis


(Pascal Golay) #2

Hi Luis- I think that depends upon the driver that is doing the printing. There may be a setting in the drivers dialogs as you print. I have CutePDF as my current driver and the pdf is not opened.

-Pascal


(Luis Fraguada) #3

I was automating the SaveAs to save a PDF, so not sure how to specify the print driver in that case. Perhaps I need to manually SaveAs once with the driver I want…


(Barry Mair) #4

Hi Luis.
In Adobe Acrobat printing preferences on the Adobe PDF Settings tab, there is a check box “View Adobe pdf results”.
Unchecking that could very well be the answer.

Barry.


(Luis Fraguada) #5

@bm_cadd Thanks for the heads up, I will check that and let you know.


(Luis Fraguada) #6

When I use _Print, I can choose Adobe PDF, and I can switch this setting off, and thus the document does not open in Acrobat. But if I use _SaveAs and save as PDF, I do not have this option, and it opens up. Does Rhino come with a default PDF printer, what happens when you _SaveAs a pdf, which driver does it use? I have something called PDF995, but this driver does not let me choose to not open the document after it is created.

I was able to do what I wanted by automating the saving of various Illustrator files, but would be nice to also be able to do it with PDFs.


(Barry Mair) #7

Hi Luis.

I just ran some tests as this issue intrigued me, and I had never saved as or exported to pdf.
I use Acrobat X and did not have it open once saved.
I did have to shut down and relaunch Rhino once I had set the Acrobat settings for it to work as you require.

I normally like to view my plot results, but turn it off when doing a batch plot from AutoCAD or Revit, so knew it definitely worked for normal plotting.

Barry.