Save as RH5 format - issues

bug

(Wim Dekeyser) #1

When saving a file in the WIP as a RH5 format file and then opening this in RH5 there are 2 issues:

  1. (reported earlier) The ground plane is turned on. I suppose this one is complicated because there now are settings for this in the display mode to override the document setting. I opened 4 factory-default templates in RH5 and none of them have the ground plane turned on - perhaps the default when saving as RH5 from RH6 should be to turn it off?

  2. A message box pops up saying “Turning on current layer.” and a layer that was not the current in RH6 (and not even on - just happens to be the top-most layer) is turned on and made current.


(Brian James) #2

This is because the GP is on by default in v6 and also set to shadow only. If you disable it in the Rendering panel prior to saving the v5 version it will be off in v5. Since v5 doesn’t have the shadow only option the fact it’s on could certainly go unnoticed I agree. In v6 the ability to turn on the GP in a display mode’s advanced settings is also possible but shadow only will prevent it from being seen in a shaded modes without shadows. Since v5 doesn’t have the shadows only GP option it would be seen in shaded modes which is probably where the issue is. I’m not sure what makes the most sense here since it is working correctly when saving with the GP off back to v5. I can imagine expecting this setting to be preserved as much as expecting it to be off. Are you thinking a check box is needed in the save as dialog specifically for the GP or is it easy enough to turn it off in the Rendering panel prior to legacy saving in v6?

I’m not able to reproduce this. Can you send or post a 3dm?


(Wim Dekeyser) #3

On this PC it’s even weirder it seems…
I launch Rhino and call New and pick a factory default template.
Make a box on the default layer. Make a new layer under that one and move it up in the layer manager.
Then make a clipping plane and move that to the new layer. Give the default layer another color and save. Exit Rhino and launch Rhino again and open the last file. Now the box is on the clipping plane layer…

After reopen:


(Wim Dekeyser) #4

I’ve just repeated this on another PC (different OS, different GPU, different everything - only same Rhino version) and the same happened here. That is, after exiting Rhino after having created the box and stuff, Rhino crashed on exit - report sent in.

Rhino is just crashing all-the-time with the latest WIPs… Time to take a break guys!
Happy holidays!


(Wim Dekeyser) #5

Yes.

I’m not sure if one should put any resources on issues related to legacy saving. But if you guys have experience in legacy saving occurring all the time then - given that the GP is fundamentally differently handled in RH6 - I would suggest an automatic disabling of the GP when saving in the RH5 format.

… checking some more now…
I’m confused now :confused: I’m going through the Document Properties and Rhino Options in RH5 now and cannot find any reference to the Ground Plane there. The only place to handle this is when calling GroundPlane. But obviously there must be a setting in the .3dm format for Rhino 5 because else this wouldn’t carry over from RH6. So that must mean that the setting just is not exposed in the the Document Properties?

At any rate, if people need to legacy save it probably won’t be for the display features of RH5 but either just to get a hold of the geometry or because of legacy plug-ins. I would just disable the GP…


Weird grey box
Background V5 file created by V6
(Pascal Golay) #6

Hi Wim - I can repeat this much at least, so far - thanks for the detailed instructions.

https://mcneel.myjetbrains.com/youtrack/issue/RH-37296

-Pascal


(Pascal Golay) #7

Hi Wim -
I see this, thanks…
Hmm - not every time though… it seems to be related to the adding-a-layer-and-moving-it-up bug you mentioned above.
-Pascal