Save As makes my Rhino5 go berzerk

Hello, I just fired up my laptop, opened Rhino5 to see if I could save a file as a .3ds or .obj file (just to see if I could export those file types), and when I click the tiny arrow next to the .3dm after clicking Save As, the whole screen flashes white and freaks out, and the file type menu does not stay put like it is supposed to.

Has anyone else experienced this? Is there a service release or releases that might fix this bug? I recentely had McAffee install virus protection and do a computer cleanup remotely after accidentally downloading that Vostran searchengine hijacker virus thing. Could that have screwed something up? I need my Rhino programs to work flawlessly!

Thank you very much,
from Nathan

Hi Nathan - that is new to me- can you provide some details on the machine and Windows version? Is Windows completely up to date?


Here’s a link to the latest Rhino 5 service release to try first

If that doesn’t fix it, you may need some updates from Microsoft, specifically the .Net framework. This should be handled by the Windows updater but make sure to check that the update succeeded in the update history log.

Hello, I have an HP laptop running Windows 7, 64-bit. I just got off the phone after an hour of McAfee Tech Support, and they couldn’t figure it out. We checked for Windows updates, and nothing showed up as necessary or recommended, nothing about the. Net framework.

We tried Saving As in Microsoft Word, and it was able to Save As normally in other file types, and the Save As menu doesn’t flash on and off, nor get stuck in a flashing white freakout.

Also we uninstalled Rhino 4.0, Rhino 4.0 SR8 and SR9, and everything from Rhino 5.0. Then I reinstalled Rhino 5.0, and tried the Save As again and it still freaked out. Then I installed the SR10 Rhino 5.0 update, and it still freaks out in both the 32 and 64 bit versions.

I took a video with my iPhone. Would that help to see? What do I click to upload it?


Hi Nathan - try TestToggleFileDialog - does that get you something that works?


Hmmm, what’s the TestToggleFileDialog? Do I go into Rhino for that? It didn’t show up when I searched programs.

Sorry- it’s a Rhino test command - type (or copy/paste) the whole thing to the Rhino command line, then try your Save operation…


I typed in the command bar and pressed enter, then tried Save As again, flashed three times, then the menu stayed put. Then I tried it again, and it totally flipped out.

I also just tried the Save As with RhinoGold and still the glitch happens.

Hi Nathan - please try disabling RhinoGold in Options > Plug-ins and restart Rhino - is there any difference in behavior?


Strangely I just reinstalled RhinoGold 4.0 and all the trimmings (Clayoo, RhinoEmboss), then I was able to use the Save As. But then I closed Rhino 5, and reopened it, and still not working again.

Went into the Rhino 5 Options page (the Gear Icon right?) and to the Plug-Ins. RhinoGold is not listed as a Plug-In, though I was able to uncheck RhinoEmboss and RhinoRender (also TDM Solutions programs). Under the RhinoGold part there is no option to un-plug it or disable it. Should I just uninstall the RhinoGold and all the extra plug-ins for that to see if that helps?

Hi Nathan - RhinoRender is the default renderer for Rhino. Don’t mess with that one. I would uncheck the ‘Enabled’ box for the RhinoGold, Clayoo, and RhinoEmboss plug-ins and see if the behavior changes for the better- if so, then enable one at a time until you can see which one is culprit.


Oopsy, I rechecked the RhinoRender. I found where I can view All PlugIns and disabled the RhinoGold and closed/reopened Rhino 5. Looks like you are right, RhinoGold or something else related to that is the culprit! Now I’ll see if I can figure out which is the buggar…

Okay, so I Disabled the RhinoGold, Clayoo and RhinoEmboss plug-ins. I re-Enabled RhinoGold and the SaveAs appears to function and stay open, I can select a new file type…I still get a white screen flash but the menu doens’t disappear like before. So looks like regular RhinoGold thus far is okay to have going.

But I tried Clayoo AND RhinoEmboss, and when either of those when Enabled I get the SaveAs glitch.

But I noticed that even when Enabled the Clayoo and/or RhinoEmboss, and I closed/reopened Rhino 5, they were not appearing at the top of the Rhino 5 window like RhinoGold (and Flamingo, etc) were showing. Looks like they are not ‘Loaded’ plug-ins currently. So I will see if perhaps being Enabled AND Loaded makes a difference.

I really want Clayoo to work, that’s a valuable program similar to T-splines.

@rafaeldelmolino, any ideas here? thanks… -Pascal

Still glitchy with just the RhinoGold again. But I right-clicked on Clayoo in the Plug-Ins menu in the Options to Load it. So it showed as Loaded, however when I restarted Rhino 5 it was still not showing up at the top. But definitely some issues with the RhinoGold TDM programs, so I’ll see if they have any updates that might solve the problem.

Thank you everyone for helping with this issue!

I don’t understand how RhinoGold or another of our products can affect to Save! We are not managing Save commands.
@CarvedMetal please contact us to, and one of my colleges will connect to your computer to check the installation. It will be the faster solution.
Rafael del Molino
TDM Solutions SL

Yeah, it’s a strange occurrence. Right now I downloaded the most recent version of RhinoGold just now, and am installing it. Maybe that will work, fingers crossed; but if that doesn’t work I’ll contact TDM support.

Talk to you soon either way…
thank you!

Posting a screenshot of the settings on the Rhino Options - View - OpenGL page might be useful too.

@rafaeldelmolino, you might want to ask Dale F about the Save dialog - there was a conflict of some kind in the past - not with RhinoGold particularlly but some machines did not like our fancier Save dialog, so that is why there is the testToggleFileDialog command.