Save As failure bug 6.16.19134.12066

I have been working away happily in a file that I did a ‘save as’ of. Turns out Rhino V6 WIP failed to actually perform the save as function and I was working in the original file. No UI warnings that the save as failed. Nothing. First I realised was when I went to open the original file.

This is obviously quite dangerous as far as bugs go.

I have since tried again and it is repeatable. I have a feeling it is linked to the earlier bug I reported about WIP reporting that a file can only be opened as ‘read only’ for no good reason.

This is with files saved on a Synology NAS.

edit: link to earlier thread about read only files: Read-only file

SaveAs works for me in the Mac WIP…

both by calling the command SaveAs as well as via the File menu then option key.

how are you triggering the command? are you sure it’s saving to the location you think it is? (location in the dialog)

Believe it or not, I do know how to save as. Are you working with files on a server or more specifically on a Synology Nas?

no… local files and icloud synced folders (desktop)

i guess i replied without reading the last sentence in the original post.

Hello - I assume you’ve checked that this does not happen if you save locally, correct?


Hi @pascal,

Yes, I have not yet come across the problem with locally saved files

I am still suffering with this issue. It is really very tricky and can very easily catch you out and this is on the Beta Version 6 WIP (6.16.19155.12084, 2019-06-04)

I should add that it seems to include a problem with simply saving changes to files. For example, just tried to quit Rhino and the floating window came up asking if I wanted to save changes. I clicked save and nothing happens. File isn’t saved, rhino doesn’t quit.

I’d say this is a pretty major bug.

@dan - do you have an idea about this?


I have no idea about this. It sounds like it is easily reproducible? Could you reproduce it @pascal?


Is this only happening on a Synology NAS?

What we need to do is reproduce this issue on our machines. What is the model of the Synology NAS?

Hi, I must say that I also suffer from this bug. Can not neither save nor save as! The workaround for this is using export command…

The only way for us to investigate this bug is by attempting to attach the same (or similar) Synology drive as NAS with the same (or similar) configuration.

What we need is the following:

  1. The model of Synology drive. @brian has a Synology drive we might be able to test with.
  2. Steps you took to connect this drive to your network. Presume we know NOTHING about Synology drives nor your network configuration.

We are tracking these reports in: RH-53222 Synology NAS file saving failures

It is a 1515+.

We have a Ubiquiti ERLite router and a couple of switches connected to it. The NAS is connected to one of those and our Macs, including my one is connected to one of the switches too.

We connect via AFP because we’ve found it to be more reliable than SMB.

The NAS drive has a fixed IP address. We have 3 hard disks in a synology hybrid raid and we have an SSD read cache.

I think that’s what I can summarise now. If you have any specific questions let me know. Otherwise I’ll try to get some screen captures of this happening next time it occurs.

1 Like

@robinp we have an 1813+ here that we might be able to use to reproduce the problem.

Can you please answer for me:

  1. What version of DSM your Synology is running?
  2. Do you have SMB, AFP , or NFS file sharing enabled. Which one(s) are you saving to?
  3. What settings are configured for each protocol? Sending screen shots of the dialogs may be simplest.
  4. How often does this happen?

I see that most of the protocols have an “enable transfer logs” setting - is that enabled? Have you looked at the transfer logs when the problem happens to see if you’re getting any events on the Synology?

1 Like

Hi @brian

We use AFP. I’ll take some screen shots of the config tomorrow and send over.

Thanks for yours (and others) time on trying to resolve this.


1 Like

Hi @Brian and @dan

I’ve done some experimenting and I’ve separately been in email correspondence with @BrianJ about some of these issues.

It took around 2min 30sec to open the file this morning with extremely high CPU use. I’ve emailed Brian James a screen shot of this.

Crucially, it is the same whether opening from Synology or from my Desktop. While Save As is successful to my Desktop, it takes a similar amount of time and CPU to do it.

We have SMB enabled for Windows machines.

Below are some screen shots. The log seems to suggest the files were all read successfully very quickly. Then followed the period of high CPU use. It seems that it isn’t the reading of the data but rather the processing of it that is the problem (given the similar problems reading from desktop too).

The file has opened as ‘read only’ though and I’ve managed to do a Save As to the Synology. I think I’ll have to capture more info when the save problem reoccurs.


It’s probably worth adding that I’m using a 2018 MacBook Pro 13" given the issue, or at least some of the problem seems to be relating to my machine rather than the Synology.

The remaining question I’ve not answered yet. The answer is I’m not 100% sure but it is definitely intermittent. I think it tends to happen after working on the same file for an extended period of time. In honesty, it is quite hard to identify exactly when it starts occurring because normal saves don’t work either and as there is no UI to say that it has failed, I just carry on as if it had successfully performed the save.

I note that you pointed out earlier that the status on the bottom left should report success or failure. It does not in these cases. There is simply no feedback.

A strange phenomenon, but this opening in ‘read only’ mode is pretty random. I’ve just opened these four files (took about 30 mins in total!!). Two have opened in read only and two have opened normally. All are in the same location.

The permissions are the same for each file (both as reported by macOS and Synology)