Sandcastle conflict with RhinoCommon version

unhandled

#1

Hello,

I’m struggling with the sandcastle documentation from a Visual Studio Project for Grasshopper components.
The project references RhinoCommon.dll (Version 5.1.30000.10). I added the same file as reference to the Sandcastle Project. However, the build step fails because of an unresolved assembly reference to RhinoCommon (Version 5.1.30000.4).
I suppose Grasshopper is referring internally to that version? But I have only the newer version on my computer. Do you have any hints how I can proceed to get the sandcastle documentation? Or am I missing something else?

Here is a part of the build log:

[...] References to include (excluding framework assemblies): RhinoCommon, Version=5.1.30000.10, Culture=neutral, PublicKeyToken=552281e97c755530 [...] Generating reflection information... [C:\Program Files (x86)\MSBuild\12.0\bin\MSBuild.exe] MRefBuilder (v2.7.4.0) Copyright c 2006-2013, Microsoft Corporation, All Rights Reserved. Portions Copyright c 2006-2013, Eric Woodruff, All Rights Reserved. Info: Loaded 1 assemblies for reflection and 2 dependency assemblies. MREFBUILDER : error : Unresolved assembly reference: RhinoCommon (RhinoCommon, Version=5.1.30000.4, Culture=neutral, PublicKeyToken=552281e97c755530) required by Grasshopper [...] Last step completed in 00:00:01.7911 SHFB: Error BE0043: Unexpected error detected in last build step. See output above for details.

Thanks for your help!

Enza


(Menno Deij - van Rijswijk) #2

Maybe you need to redirect assembly version.

http://msdn.microsoft.com/en-us/library/7wd6ex19(v=vs.110).aspx


(Steve Baer) #3

I’m confused as to why you are trying to generate SandCastle documentation for Grasshopper. You should be able to get this from Grasshopper by clicking on the help menu. @DavidRutten may also post this information somewhere else online, but I’m not sure of the location right now.


(David Rutten) #4

Enza seems to be creating SandCastle docs for his own components. I do indeed use SandCastle to generate GH SDK documentation which can be downloaded via the Grasshopper Help menu.


David Rutten
david@mcneel.com


(Steve Baer) #5

That makes sense. I guess the quickest solution may be to just email Enza the RhinoCommon assembly that you are compiling against.


(David Rutten) #6

If that’ll fix it, sure.

I’ve uploaded the RhinoCommon.dll that Grasshopper for Rhino5 is build against to my dropbox folder:
https://dl.dropboxusercontent.com/u/38313625/RhinoCommon.dll


#7

Great! The file fixed my problem.
Thank you all!


#8

Hello,

Same problem here to build help files with sandcastle for my own components.
I reference Rhincommon.dll (5.1.30000.13) and Grasshopper.dll (1.0.0.20) in my VS project.

But Grasshopper.dll (1.0.0.20) targets Rhincommon.dll (5.1.30000.4).

So I got the same MREFBUILDER error as Enza.

Any chance to get the right version of the rhino common.dll ?
What about the next builds when updating rhino & grasshopper in the future ?
Is there a way to tell sandcastle to redirect to the newer version of rhino common ?

Thanks for your help !
Lionel


#9

Hi David, do you mind uploading that rhinocommon dll again, I am also using sandcastle for documentation and need the DLL you mentioned here. The dropbox link is no longer valid. Thanks!


(David Rutten) #10

Sorry Luis,

that link to my dropbox was several computers ago, I no longer have that file as GH for Rhino5 is no longer developed. all current GH versions are build against the current RhinoCommon code.


#11

Hi David,
No problem thanks for the quick reply


#12

Hi Luis,

I still have the file from David’s dropbox (RhinoCommon.dll Version 5.1.30000.4).
If you want to have it, I will upload it somewhere.

Enza


#13

Hi Enza

Great! thank you, could you email it to me luis@complicitMatter.com

Thanks!


#14

Hi Enza,

Does emailing it work or would you prefer a place to upload?

Thanks again very much


#15

Hi Luis,

I sent the file to your email address.

Enza


(Dale Fugier) #16

A post was split to a new topic: Need Version 5.1.30000.10