Runtime error (MissingMemberException): 'LightException' object has no attribute 'components'

rhino
error
grasshopper
python
bug

#1

Hello,

I am using the last Version of th Rhino WIP for Mac (5E12W).

I am experiencing some difficulties to import the ghpythonlib.components as ghcomp
Every time I get an error: Runtime error (MissingMemberException): ‘LightException’ object has no attribute ‘components’
I have searched for any solution but didn’t find anything that have worked.

I have tried to reinstall the Rhino and also was trying to install the Python Component, but nothing have worked.

I hope that someone could help,
Best wishes,
Iurii


(Dan Belcher) #2

@piac is this something you are able to reproduce?


(Giulio Piacentino) #5

Hi @Iurii_Suchak

ghpythonlib was developed as a Rhino for Windows feature. It hasn’t been tested and manually ported to the Mac, yet. Codebase is similar and right now it is probably a port of the Windows version, so there are chances it will work. Once it will, I’ll make sure you know.

Giulio


Giulio Piacentino
for Robert McNeel & Associates
giulio@mcneel.com


(Giulio Piacentino) #6

I added a bugtracker item: RH-38180.


#7

thank you!


(Stmichael6) #8

Hi Giulio,

Any update on when the ghpythonlib will be ported to Mac? I tried to run the import and got the same errors as lurii.

thanks!


(Dan Belcher) #9

No timelines, I’m afraid. That said, I’ve bumped RH-38180 in priority a little.


(JoannaMariaLesna) #10

Hi Giulio,

I have the same error, but I am working on Windows.
Solution exception:‘LightException’ object has no attribute ‘components’
Do you have any idea how to solve it ?


(Giulio Piacentino) #11

@joannamarialesna this is certainly an issue having to do with:

You can fix it by uninstalling the independent IronPython installation.

Giulio


Giulio Piacentino
for Robert McNeel & Associates
giulio@mcneel.com