Runnning _TextObject causes crash and strange display


Today while running _TextObject in the V7 WIP causes Rhino to crash. It works fine in V6 and worked in V7 recently.

The first time I experienced this:

I ran the command > typed words using the new “SLF-RHN_Architect” typeface (I love it BTW) > Pressed OK > When asked to place the text base point, I noticed the text was not displaying correctly with letters missing and not all in line (it was just two words.) > Crash occurs upon picking the base point. It did not ask me to recover the file when I reopened the V7 WIP.

During subsequent attempts to use this command today, it crashes when upon initiation.

Anyone else experiencing this?

“SLF-RHN_Architect” works fine with _Text and _RTextEdit.

There is no reason that I need to use this font with _TextObject. Was just saving myself from exploding it later on.

Rhino 7 SR0 2020-8-4 (Public Build, 7.0.20217.03575, Git hash:master @ 31b1a3c260f17d78fb19ebf37e76b172f5dda99a)
License type: Commercial, build 2020-08-04
License details: Cloud Zoo
Expires on: 2020-09-18

Windows 10.0 SR0.0 or greater (Physical RAM: 32Gb)

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA GeForce GTX 980 (NVidia) Memory: 4GB, Driver date: 7-24-2019 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 432.00

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 7-24-2019
Driver Version:
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 4 GB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7 WIP\Plug-ins\Commands.rhp “Commands” 7.0.20217.3575
C:\Program Files\Rhino 7 WIP\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7 WIP\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.0.20217.3575
C:\Program Files\Rhino 7 WIP\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.0.20217.3575
C:\Program Files\Rhino 7 WIP\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7 WIP\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7 WIP\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.0.20217.3575
C:\Program Files\Rhino 7 WIP\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.0.20217.3575
C:\Program Files\Rhino 7 WIP\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7 WIP\Plug-ins\Displacement.rhp “Displacement”

Works, wip (7.0.20217.3575, 04.08.2020)

1 Like

Hi Ryan -

Does it crash on you if you run Rhino in Safe Mode?
If not, I would try to update the drivers for your GTX.

If it does, are you sending in the crash reports?

Hi @wim, It does still crash in Rhino WIP safe mode.

There was no pop-up asking me to submit a crash report to mcneel. I don’t know if there is another way to find it. Maybe it’s not being generated?

I was able to recreate this in the current version of the V7WIP on both Windows & MacOS.

Run _TextObject and select these options:

It will produce output only for the objects that are closed curves - the dot above the “i” and the “o” character in this example. Same results if you select “Solids” instead of “Surfaces” as the output type.

Subsequent calls to _TextObject cause Rhino to crash instantly even after restarting.

You can recover functionality of the _TextObject command by running the command _-TextObject and changing the output type to Curves (or changing to a font that is not single stroke).

Selecting the “Engraving font” option automatically switches the output type to “Curves” but it seems like a bug that selecting “Surfaces” or “Solids” as output type causes Rhino to crash on subsequent calls.

I saw several crashes while looking into this and never saw the crash reporting dialog.


1 Like

I’m unable to repeat this.
I tried using a build just prior and a new one from today.

No issues using that font.


I don’t think it’s a logical action. How can it build a surface or a solid from a single line?
It is evident that in this case they did not include protection from fools.

I agree that attempting to build a surface or solid from a single stroke font is an invalid operation. Rhino should detect this and notify the user - not go into a loop of program crashes.


Good Thinking. It didnt occur to me to suppress the dialog box.

But yes, at very least the options that cause Rhino to crash should be grayed out as to not accidentally cause this (and loose data)… like I did.

Oh, the woes the WIP!

Hi Kevin -

Thanks for those steps. I was able to reproduce this here and put it on the list as RH-59796.

RH-59796 is fixed in the latest WIP