Running Rhino on Citrix XenApp XenDesktop

I’ve tried to run Rhino 4 and Rhino 6 on virtualized environment through Citrix XenApp, XenDeskop, but was not sucessful. Even with running educational lab licence at school Zoo, Rhino doesn’t run on one VM (one IP address) for more than one account. By looking at other SW products like Autodesk AutoCAD or SketchUp, which have no problem with Citrix, question comes to my mind:
Do you plan to develop new Rhino version which would work on Citrix XenDesktop, XenApp platform? Looks like there is more and more interest for this platform worldwide. Thanks for info.

@Brian - any idea about this?

-Pascal

Not recommended:
https://wiki.mcneel.com/rhino/citrix

Hi John

My question is not if actual version works on Citrix. I know that it doesn’t.
My question is if there is a plan to make it work on Citrix as other 3D, 2D graphical applications do.

I am not aware of any development work or plan to support the Citrix platform.

Hi @licencie,

There are two reasons we haven’t recommended running on virtualization environments in the past:

  1. OpenGL Video performance can be terrible on shared systems
  2. Getting smooth full-screen graphics updates over the wire were slow

Both of these things have improved dramatically over the last five years or so, and so it makes sense for us to revisit this.

Can you tell me more details about:

I hope we can make Rhino work in these environments so you can decide for yourself whether it works well enough to deploy.

Hi Brian

This is very reasonable answer. Performance of nvidia tesla GRID cards is quite interesting to utilize, so it would be great to see Rhino in Citrix environment really. Thanks.

@licencie you’re welcome…

and, I’d love your help investigating the problem. Can you tell me more about what didn’t work for you?

Sure. I’ve activated Zoo with given licences and then started Rhino 4 on one of VM, it worked fine.
Then I started other Rhino 4 instance on 2nd VM, it worked. But when I logged with other user to first VM and tried to run Rhino, it stopped at splash screen, retrieving licence from zoo and everything hanged. Looks like this is computer name dependent. For instance Sketch Up 2019 Pro, you just simple put your gmail address in when app is starting and it doesn’t care about computer name and fact, that you connect more users to one VM akka one computer akka one IP address…

Did you try Rhino 6 using a license in the Cloud Zoo?

Nope, school has only Rhino 4 educational lab licence

Trial for Rhino 6 doesn’t allow zoo

Ah, well that’s not a big surprise. Rhino 4 and its accompanying Zoo was written before these products were even dreams. I’d like to work directly with you to find a way to test Rhino 6 in your environment. I’ll direct message you…

Perfect, thanks a lot

Hello, anybody able to get hold of Brian? He’s not responding to me. Thanks a lot.

Hi - Brian is off until the end of the week.
-wim

Hello, thanks for info. Maybe anyone else could help? I’ve installed Zoo 6, but when I run it, it takes default port 80, so it collides with Citrix Storefront. Is it possible to change it somewhere? Thanks.

Hi again - no, it’s not possible to change the port the zoo listens on but perhaps the following helps?


-wim

Thanks Wim, yeah I will have to change IIS port for test. Cheers.

One more question… what would make you think about developing Rhino to support virtualized platforms? Doesn’t have to be necessarily Citrix. Would that be technicaly possible? Difficult? What would you need in general to make it real?