Run 'Squish' command from Rhinocommon

Hi all,

I need to run the ‘Squish’ command from a plugin, but I’m not getting it to work. As I’ve got the ID of the object needing to be squished, so I’ve tried writing.

RhinoApp.RunScript($"_-Squish _SelID {id} _S _Yes _P _No _D _Free _M _Rigid _O _Down _E _No", false);
But when I run that, Rhino comes up with ‘Please select the object to Move’.

Alternatively, if I leave the parameter Identifiers out, and just type
RhinoApp.RunScript($"_-Squish _SelID {id} _Yes _No _Free _Rigid _Down _No", false);
Rhino does get the ‘Squish’ command, but picks neither the id, nor does it take any options.

In any case, I’m not getting to run the squish command, select the object and set the parameters. As the Squish command cancels any previous selection, I need to select the object inside the command, rather than pre-selecting. Can anybody tell me how I can do that, what I’m doing wrong?

Thanks,
Marie

Hi @m.romland1,

Make sure to read this first:

Also, I’m thinking this should work:

RhinoApp.RunScript($"_Squish _SelID {id} _S=_Yes _P=_No _D=_Free _M=_Rigid _O=_Down=_E _No", false);

– Dale