Run solver for a certain period of time

unhandled

(Emmanuelle Vanhaesendonck) #1

Hi, I am working with a solver, to divide a line into equal straight parts. This is working good, but sometimes the solver stays counting until the lines are exactly the same, and then my rhino crashes/ is blocked. When I had this previously, I bake my lines that were the result of the solver immediately, and then disabled the solver. (but it took a long time to do this) Now, I need to construct further in gh on the result of the solver, so I need him to stop counting… When I change the value from the on parameter on the solver, to ‘set bolean false, in stead of true’ he gaves immediately 1 value (without staying counting), but far away from what the result should be. Is there any possibility to say for example that the solver can work only 5 sec, to prevent him from staying working for ever…? Disabling the solver gives as result my result is gone, so this is not an option. Thanks!


(Daniel Piker) #2

I’m not sure I follow.
Setting a ‘False’ input to the ‘On’ parameter of the solver will pause the solver at its current iteration, and the output will remain whatever value was reached at that point. There shouldn’t be any need to disable the component.
You can also modify the ‘Threshold’ parameter to make the solver stop sooner - the default here is 1e-15, but you could try something like 1e-9.
Also, I notice you are using an older version of the solver component. Here’s a file showing it with a more current one:
equalsegments.gh (12.9 KB)


(Emmanuelle Vanhaesendonck) #3

@DanielPiker Great!! It works! I can move on with my drawing :slight_smile: thanks!
Thanks for the solver. - I changed the solver, but then he doesn’t want to work anymore… (One or more errors occured) if you would have read it, it’s working now, I needed to press the button…