RTX 3000 Series and RhinoCycles

I have the feeling that this is the issue. What can I do to fix it?

From the callstacks as far as I can most of the steps go fine, even the compiling of the kernel from the PTX file. The CUDA kernel functions used as utilities are loaded fine. What fails is apparently the creation of the pipeline.

From the callstack it looks like you have a driver from September. There is a newer one for RTX 3080 from November 9th. Please try updating to that and see if it helps any.


Yes, it was the latest available “Studio” driver. The latest “Game Ready” driver is newer. I installed it, this probably triggered the first time loading when switching on optix again and this time I did not kill the process. Patience was probably the key. Works fine now. Thanks, now looking forward to play around with it.


  • On the previous driver install I had unchecked “PhysX”, I thought it’s not necessary. This time I kept it checked. Not sure if it is related.
  • General: always uncheck “Geforce Experince”. This bloatware that Nvidia want to install is terrible.

Neither PhysX nor GeForce Experience are needed.

1 Like

there is weird stuff going on with optix renders. compare…



I’m on RH7SR1

That happens with the ground plane only. It is on my list, but no ETA for fix.

the artefacts are still there when I turn off the ground plane. other render settings: backdrop solid color, custom environment for reflection and for skylight.

hope it’s a simple fix.

Hmm, not seeing that here. I have been testing OptiX for weeks quite extensively

Can you share a file with which you see the error?

@nathanletwory I see artifact on optix here too with my quadro rtx 5000

Looks like disabling the groundplane through the Rendering panel doesn’t work. It is still enabled. But if I disable it in the Ground Plane panel the groundplane gets properly disabled.

can you start a new thread for this and post your systeminfo please? That way it gets the attention it deserves and doesn’t get ignored for the original post.

1 Like

Will do first thing tomorrow, I am on my phone now. Thanks