Rooster plugin in grasshopper adding extra point to the image

Hi everyone,
I am using Rooster Plugin in Grasshopper to convert my 2d image in curves and then to 3d model, but I am having a weird problem. It is adding one extra edge to the image as seen in the image below.


There should have been 6 edges in this brep but there are 7. The blue circled is the extra point/edge that rooster is adding.
Have anyone faced this problem before or has any idea that might solve it?

Edge or point?
You can remove this point, try with Simplify curve , and it’s better if you post your definition.

Hi @seghierkhaled
It’s a point, which is breaking that surface as you can see in image below

2d-3d via rooster.gh (14.0 KB)
I tried simplify curve but it still breaks the surface, and the added point is always on the west side for all the other images I try, image below shows that

Looks like you use old version of Rooster.

As i told you try with Simplify curve

Work fine for me

could you Please also share the Gh file for this. The point dissappers for me but the wierdly the surface is still divided.

2d-3d via rooster_2.gh (18.5 KB)

@seghierkhaled
I downloaded the new rooster but now it doesn’t work for me I am getting an error: 1. Solution exception:Could not load file or assembly ‘nQuant.Core, Version=1.0.3.0, Culture=neutral, PublicKeyToken=null’ or one of its dependencies. The system cannot find the file specified.
do you know I could solve this>?
And also for I opened the gh file you sent, It is still divided for me :frowning:
1

Do you copy all these files in …AppData\Roaming\grasshopper\Libraries ?

image

And for the point this is weird can you take a screenshot of the definition ?

@seghierkhaled
Yes I did, I copied all three files still it’s not working, My whole workflow depends on this plugin and now it doesn’t work :frowning:

Use the old version,it called Rooster , the new version called Ghpotrace simply remove it

Thank god I had the older version, the newer version just didn’t work for me.
But still back on square 1. Thesimply tool removes the extra point but when I extrude it, the surface is still divided.

I have no idea about this, it is weird
Try to extrude the curve only and see if the edge disappear and check the tolerance.

@seghierkhaled
It still appears when I try to extrude the curves only, I don’t know why it works for you and not for ma :confused:
which version of rhino do you use? I use rhino 5, could that be the cause?

Maybe this is the problem.
Try this

1 Like

@seghierkhaled
Perfect, worked like a charm. Thanks alot! :grinning: