RMB/Right-click for Enter delay/lag/non-register is really infuriating

  1. Make EE alias for Extend
  2. Type EE, RMB Click, 12, RMB in quick succession.

Second RMB will NOT register. I literally have to wait a moment to make it register. Space, Enter will register just fine, like the input would stack even if pressed earlier, just not the RMB.
R5 had the same problem but a lot less pronounced and I managed to live with it. Now R6 has it “just right” for me to post this.

It significantly slows me down as I use Extend ALOT. I’m not going to start using Space to run the command as I never have in my life since AutoCAD 2000.

Another way to reproduce the lag is:

  1. Create a surface
  2. Create a line running over it. Select it.
  3. Run TR (Trim), click on the surface to trim it
  4. RMB to finish Trim command, hit D (Delete) and RMB to delete the line in quick succession.

Second RMB will NOT register in this case.

This is such a PAIN IN THE ASS to have to wait for R6 to wake up and register my RMB. It’s beyond annoying!!!

Just overall fast keyboard command input followed by RMB will make R6 not register RMB nearly EVERY TIME.

  1. Run Undo
  2. Double RMB click to undo 2 more times.

Second RMB will not register. Enter or Space WILL.

I’m trying to reproduce it here and the only way I can is to be clicking so furiously quickly that I wind up MOVING the mouse, which yeah is not going to register the RMB as a click but as a click-drag. I don’t think there’s a setting under the Rhino mouse options to set that sensitivity.

Hello - try the ‘*’ repeater character for Extend



That’s how I work. Furiously fast. R6 makes me work at average joe’s speed. :frowning:

It didn’t really do anything, it just makes EE to repeat. I don’t need it to repeat, I need RMB to register the same way Space and Enter register. I bet the latest i9 would eleminate that lag, but I’m surprised 3.5MHz i5 struggles to make RMB not lag. (My work machine with i7 sometimes doesn’t fail)

As I said it affects more than just Extend command. It affect fast input in general. It makes me work slower than I can. It’s a major drawback of R6 to me. I can find workarounds for bugs and missing features, but this issue affect nearly every command input I have to make.

It’s like here’s Ferrari, but to shift gears on it I have to press clutch twice, press that button and then shift.


1 Like

i have noticed a similar issue, mostly on a multiple-copy command issue.

draw some object.
run copy command
select object
choose base point
input direction and distance with mouse selection
use sub-command options to select F,S,U for multiple copy in same direction and distance
LMB click successively in direction that you want copies to be produced, only 2nd or 3rd rapid clicks will register.

No, the idea of mouse clicks “ghosting” is absurd, that’s not a thing that exists even in the world of gaming. You’re moving the mouse, triggering a drag input instead of a click based on how far it’s moved. V6’s sensitivity may be different from V5’s, but it generally would be set pretty sensitive otherwise making slight view manipulations would be irritatingly laggy. Also, a workflow that involves so much right-clicking is just…weird like what are you doing??? I suppose you could try instead of using the right mouse button, using another button on your mouse mapped to the Enter or Space keys, which would not be ambiguous.

No, I’m not moving my mouse when I press RMB fast. Stop your nonsense, I know when I do that and that’s another whole issue that I’m not gonna bring up, 'cause it’s my own fault. R6 treating RMB as low priority input or w/e causes the issue is a huge deal for me.

What I’m doing? I’m using it as Enter. I don’t use any toolbars or icons and input all commands with 1-2 symbol aliases. R5 was bearable. One miss out of 10. R6 is all misses or use space.

Let me take a guess here…“Its fixed in R7 WIP, use that.”
Isnt that how it goes?

@brian any idea? Need better CPU? I’ve got i5-4690K at home and it’s unbearable. i7-6800K at work is better, but still sucks missing RMB clicks.

I don’t see that, even copying enough geometry that the display can’t actually keep up with the clicking.

Yep, that’s most likely a display issue, but expected behavior is that mouse clicks should be registered and stacked.

@Asterisk I wonder if this has to do with double-click speed on your computer. When you click twice in rapid succession, Windows interprets it as a “double-click” instead of “click” then “click”. In this case, Rhino gets a “click” event, and then a “double-click” event. My guess is that Rhino doesn’t have a right-double-click handler.

To see if my speculation is true, try setting your double-click speed in Windows (in the mouse settings in control panel) to something really short - perhaps faster than you can actually double-click. That should make it so that Rhino sees two clicks in “rapid” succession.

If this is the case, and setting the double-click speed quite short works for you, then problem solved. If this causes other problems, perhaps we can tweak Rhino to handle double-clicks the same as single clicks. My guess is that this would happen only in V7 because who knows what else would get screwed up with this change.

1 Like

I have set Windows to single click open files, instead of double click - would be interesting to see, if that could solve your problem…

Amazing! That was it! It fixed the issue 99% of the time (the rest of 1% I was too fast even for myself).


Dam Windows… Who woulda thunk…


Well the most likely culprit, based on anything I’ve seen here or experienced myself or Googled about windows in general, was that it was the mouse mechanically failing. Some Windows thing would be the next option.

1 Like