Ring profile wonky and disjointed

Hello I have Rhino 7 evaluation on a Mac which I’ve just started learning. I’ve been creating D profile rings using Sweep 1 with much success but then something suddenly happened to the ring profile I’m building: the shape is joined into 1 curve and looks fine in Right viewport but appears wonky and disjointed in the other viewports. I’ve tried reseting the Viewports but that didn’t work. Then I deleted the project and started a new one but exactly the same thing is happening. I’m a bit confused as it’s only just started happening. Please could anyone advise me how to resolve this? I attach a screenshot. Thanks in advance.

Hello - in the Right view run ProjectToCplane with DeleteInput=Yes. (But, if the thing is round, that is, the sweep path is a circle,why not use Revolve rather than a sweep here?)


Thank you Pascal. I’ll try that. The simple answer is I haven’t got to Revolve yet! I’m a real newbie!! Diane

1 Like

Well that fixed it a treat! Many thanks for your quick reply. Would I have avoided that by ticking “Project”, bottom left of the screen before creating the profile?

Yes - if you got it that way by snapping to geometry that is off of the CPlane, then Project would shove the snap back onto the CPlane. See also the Planar setting and how it interacts with drawing and Project.


Gosh I’ve no idea if that’s what I did!! But I’m glad it fixed it. This is a steep learning curve!! Thank you so much for your help. Diane