Rihno noob here - How do I "extrude" between two closed curves?


#1

Hi,
I want to make a mesh between these two closed curves:

(one is on top of the other) so the result would be a tube with radial fins on it.

I’m not sure which command to use,
any help would be appreciated.
Thanks.


#2

You could use Loft and PlanarSrf.
Select the bottom two curves and PlanarSrf.
Select the top two curves and PlanarSrf.
Select the outer curves and Loft.
Select the inner curves and Loft.

There are other ways to do it, but this would work. I’m sure some Rhino gurus here could do it in one step.


#3

Thanks,
thats exactly what I was look for.
How do I merge the 4 resulting surfaces into one mesh ?
The Merge commands don’t seem to work.

Another question, I want to make it bulge in the middle,
to it would have a vase shape. Any ideas ?


(Margaret Becker) #4

Make another set of curves for the widest part of the bulge. Include in Loft.


#5

Thanks, that worked well.
How do I cap the loft and made a closed mesh ?


(Margaret Becker) #6

Cap command or
PlanarSrf command using surface edges as input
Mesh command


#7

Cap doesnt work, error :
Unable to cap one object. The openings did not have closed, planar loops of edges.

I tried PlanarSrf and then Mesh, the result is 3 separate meshes (body and two caps) that I can’t
find a way to merge. Am I doing something wrong ?


(Margaret Becker) #8

Maybe… It would be best if you can upload your model so we can see the actual objects.


#9

Here :
https://dl.dropboxusercontent.com/u/623478/LoftTest.3dm

This has the origial curves I Lofted, the surface that was created from that,
and a mesh created from the surfaces.

Thanks !


#10

Hmm if you Join up the end surfaces that works, but something isn’t quite right, it should finish the Join operation automatically after picking the ends. Can’t see anything wrong with the curves.


(Margaret Becker) #11

And I can’t see anything wrong, period.

Join command - pick top, bottom, and lofted surface. You get a closed polysurface.
Mesh command on closed polysurface. You get a closed mesh.


#12

But for me it doesn’t as I said automatically end the Join after picking them, though it does result in a closed polysurface. And Cap doesn’t work. So one would guess something is microscopically not-quite-flat somewhere, or off in a curve.


#13

Join worked.

Thanks everyone for your help !


(Margaret Becker) #14

I guess I should ask what version of Rhino everybody is using, here. I am on Rhino 5.5.