Rigid body error - Eigen modes

New to karamba but longtime gh user. Been trying to set up a basic beam analysis of a wood zollinger structure but haven’t quite figured it out - I have the error of multiple rigid bodies as I’ve seen many places on this forum:

I’ve scoured the forum and always see Clemens suggesting to use the Eigen modes to check (I have placed the component but don’t know how to use it to check). I’ve checked the connected parts does not have multiple branches as suggested in other posts. (Also if it were to have that error, what is the fix? Just flattening?)
image

I’ve confirmed that the inputs are all lines as well with no duplicates… can anyone point me in the right direction? I’m fairly certain its something incredibly simple I’m missing…
20220714ZollingerKarambaTest.gh (49.4 KB)

Hi,
there are a few issues with your model.

  1. i think the units were not set properly. The standard units are m, but your geometry is modelled in mm. Therefore make sure to change the units to mm and then the error is no longer there
  2. In your model, I think the Zollinger system is not modelled correctly. None of the crossing beams are actually intersecting, meaning that these are just beams that span from the edge to the opposite edge
  3. If you are using wood, make sure to use a trapezoidal cross section. the RHS are for steel.
1 Like
  1. oh goodness what a noob thing to miss! Thanks for saving me a potentially very long time figuring that one out…

2.The tessellation is a much higher density in actuality, I had lowered it for troubleshooting the karamba

  1. Now that there’s no longer errors I’m going to set up the wood cross section - I’m browsing through the tutorials to find a good example of something like this to base mine off of - you have any in particular? What is the RHS you refer to? I’ve set up the material cross section to be a rectangle here (unless I’m doing it wrong) - don’t see a trapezoid option unless it is the T?

    The goal of this script is to optimize the global shape.

Hi,

For the material, take a look at the output, as in your screenshot, there will be more than one material in the output.
For timber rectangular sections, please use the trapezoidal shape. You need to create your own cross section with the CrossSection component:

image

1 Like