RhinoWIP / MACOS-Sierra problems


#1

Hello

I have a client with problems with his Macbook Pro and Rhino WIP

  • Most of the time the keyboard “lose” the comunication with Rhino. For example: We use command BooleanUnion, but some times we press Intro, and Rhino don’t recognize it. We need to clic the button on the window, but the Intro button on the keyboard don’t be applied. (at that moment we went to Word and verified that the Intro button works fine)

  • In some exercises the object “dissapear”. We change to Wireframe, Shaded, Rendered and many other an the object didn’t apear. (I tried the command SelAll, and inside the properties panel, appeared that we selected the object). Other times all the viewports become all in red

Thanks for your attention

Regards

Jesus Lopez

Untitled.3dm (4.8 MB)


(Dan Belcher) #2

Hi @Punto_3D-

Apologies for the delayed reply. Can you please send the following…

Can you please provide some additional information? Please navigate to Rhinoceros > About Rhinoceros > More info… > Copy to clipboard and paste the content back into a reply here.

Also, what is the “Intro” key? Is that the enter key?


#3

Hello

I apologize: Intro = Enter (sorry for translating)

Here the information of About Rhinoceros:

Software information

Software versions
Rhinoceros version: 5.4 WIP (5E140w)
Rhinoceros path: /Applications/RhinoWIP.app
IronPython version: not installed
WIP expiration: 1 de septiembre de 2017
Language: en
macOS version: Version 10.12.6 (Build 16G29)

Plug-ins
None

Third party kernel extensions
None

Hardware information

Computer hardware
Hardware model: MacBookPro13,3
Processor: Intel Core i7-6700HQ CPU @ 2.60GHz
Memory: 16 GB
Architecture: Intel 64 bit

Video hardware
Graphics: AMD Radeon Pro 450 2048 MB
Memory: 2048 MB
Screen size: 1680 x 1050
Displays: Color LCD (258dpi 2x)

USB devices
Apple Inc.: iBridge

Bluetooth devices
Unknown:
Broadcom: Magic Mouse 2

OpenGL information

OpenGL software
OpenGL version: 2.1 ATI-1.51.8
Render version: 2.1
Shading language: 1.20
Maximum texture size: 16384 x 16384
Z-buffer depth: 24 bits
Maximum viewport size: 16384 x 16384

Implementation settings
Use texture compression: Yes

Appearance settings
Antialiasing: 4x
Mip map filtering: None
Anisotropic filtering: Low

Thanks for yout attention


(Dan Belcher) #4

Thank you. I don’t see anything out-of-the-ordinary here.

Perhaps something in your preferences have been corrupted somehow.

Can you please try this…

  1. Launch Rhino for Mac and start a new modeling window.
  2. Run ExportPreferences and save a backup copy to your Desktop.
  3. Run ResetPreferences to set the preferences back to the defaults.
  4. Quit and relaunch Rhino.

Does this help?