Rhinoscript creates 5 default layers, how to disable?


#1

Dear community,

Just a short question: whenever I run my Rhinoscript, default layer 01 to 05 are created, next to the layers I add myself. Can I disable that these 5 default layers are added?

Many thanks in advance,

Kind regards,

Filip Rooms


#2

Can you post the code?


#3

In your script, are you opening a new file or importing a file that has these layers already?

–Mitch


#4

You could simply add some code to delete the 5 layers, assuming they are empty.


(Dale Fugier) #5

Are you sure these layers not not in Rhino’s default template file? (Tools -> Options -> Files)


#6

They indeed originated from my template… I remove them in an initializer function, as suggested by BrianM.

Thanks for the suggestions…

Kind regards,

Filip