RhinoDLR_plugin

I have been getting this pop up when I start Rhino, closed now, but something along the lines of Rhino_DLR_plugin cannot be loaded. I can send openGL setting soon … on my wife’s computer and she is learning Rhino.
Any ideas?
Thanks, Randy

If you can repeat it, please take a screen shot of the specific error and send it attached to a reply.
Thanks

Hi John,

for some reason the screenshot cannot be uploaded. Here is the text.

'Plug-in not Installed

The RhinoDLR_Python plug-in is not compatible and will not be installed.’

I hanks, Randy

Here is the screenshot.

thanks, Randy

You have an out of date Python module. Download the current one here: http://www.rhino3d.com/download/IronPython/5.0/wip

(I found this information by starting here: http://wiki.mcneel.com/rhino/mac/home)

I’ve started seeing this a week or so after installing 5.2 WIP (5C95w). I reinstalled IronPython using the previous link and that didn’t fix things. The file name is python20140707.machri and I’m wondering if it’s up to date.

You don’t have to do that anymore. Iron Python is included with Rhino installer. Doing this may mess up any OSX python.

Try this … http://wolfpaulus.com/jounal/mac/installing_python_osx/

iron Python is included in Mac rhino these days.
I’m not sure what you should do to fix what you’ve done but probably try deleting the pythons you’ve installed then reinstalling rhino
?

edit- oh, what randy said ; )

1 Like

Ah, removing the old ironpythong from ~/Library seems to have fixed it.

I just added an item to find and kill the old Wiki pages with links to the no longer needed Python download for Mac Rhino:
http://mcneel.myjetbrains.com/youtrack/issue/WWW-278