RhinoCycles Texture Mapping going wrong

Hi Nathan and perhaps the other people working on the materials / texture mappings,

I’m using meshes that use very specific UV Mapping attached to mesh. Each face is mapped to one pixel in the bitmap. In the latest version of RhinoCycles this seems to give a lot of trouble. No matter what I do, things seem to turn out purple.

The rhino preview and old renderer seems to work correctly:

Things I tried:

  • Change texture type to basic bitmap (there are no texture mapping options, still does not affect the final result)

Things I do not fully understand:

  • How to use the material settings to force the texture to use the object’s own UV mapping.
  • The results seem consistent with running RebuildMesh in rhino. The mesh will turn purple in the viewport.

Reproducing the error
Incorrect Textures.zip (155.8 KB)

UV mapping is indeed still wrong in several cases. I am aware of the faulty renders that get produced, these are on my todo-list! I made quite a bit of progress with viewport rendering last week, so mapping/UV problems will get tackled soon.

I’ve added your files to my collection of test files.


Cool, thanks for the reply!

So, back at work I opened your file and had it rendered. The results look correct as far as I can tell.

Here are renders with CUDA, OpenCL and CPU (the differences in graininess is different amounts of samples being stopped at, otherwise they’re pretty much similar render results):

Could you please post your WIP build version and device you’re rendering with?

Incorrect (UV) mapping is currently best seen where texture size and or repeat have been set to something different than 1.0, your particular example should render fine. (I like the model!).


Hi Nathan, thanks for the quick follow-up! That’s indeed much more like the expected results. (And a pitty that this works out to be a “Works for me” case).

This is the information for my workstation:

This is the version: Work In Progress
(6.0.15146.10541, 26-5-2015)

The devices for cycles are these:
Device 0: CPU > Intel Xeon CPU W3565 @ 3.20GHz > 0 | False | True | False | CPU
Device 1: CUDA_0 > Quadro 2000 > 0 | False | True | False | CUDA

Due to the bug earlier I’ve only tried this on this machine with CPU rendering.

I’ve tried this also at my laptop (i7 processor / Quadro K1000M with similar results).

Let me know if I can supply you with more information.

Looks like you have a recent WIP build, so we’ll have to see if you get better rendering results once the next WIP update is available, since I made some changes to what files do get copied along with the install.

If not then I have to try figure out other ways to have you run tests that might give me clues to what’s going on.

The purple might mean there is a problem with the texture in memory, but lets first wait what the next WIP update brings you. Because that’s a tricky issue to diagnose over a forum :smile:


Sure, any clue when the next WIP build is due?

Barring any big problems they generally get published every Tuesday, not sure what time really, but I think checking on a Dutch Wednesday morning you probably should see a new build.


Perfect, I’ll check it out and report back here. Thanks a lot for the help!

Ok, just checked out the latest version - seems to give the same output.

Can it somehow be messed up settings? A texture gone wrong? Invalid paths?

It’s a pity - because I had it working before - and cycles gave excellent results out of the box.

I think the WIP release failed to go out last week.