RhinoCommonXamarinStudioAddin for Xamarin Studio 6.1.1.17?

mac
plugin
rhinoformac
rhinocommon

#1

Hello !

I am very very happy to be back to Rhino for Mac !

I am trying to build my first plugin using the RhinoCommon Xamarin Studio Addin.
I am following the tutorial from here:
http://developer.rhino3d.com/guides/rhinocommon/your_first_plugin_mac/

I have three errors when trying the provided HelloRhinoCommon:

  • ETO assembly not found for framework Mono / .Net 4.5
  • Rhino.UI assembly not found for framework Mono / .Net 4.5
  • RhinoCommon assembly not found for framework Mono / .Net 4.5

I have the feeling “RhinoXamarinStudioAddIn.6.0.0.4” is for Xamarin Studio 6.0.0.4 and not Xamarin Studio 6.1.1.17. I am worried there is a versioning problem with ETO, Rhino.UI and RhinoCommon.

– I tried to change the options to Mono / .Net 4.0 etc.
– I tried to replace the RhinoCommon addin by the one from RhinoCommonXamarinStudioAddin on github: “https://github.com/mcneel/RhinoCommonXamarinStudioAddin
– I tried to replace Xamarin Studio 6.1.1.17 by an older version. But I have not access to Xamarin Studio 6.0.0.4 anymore.
– I tried to hack versions inside RhinoCommonXamarinStudioAddin.

I do not know what to do to make HelloRhinoCommon from your_first_plugin_mac work.

Thanks for your help !!!


#2

Running Xamarin 6.1.1 here and all seems fine. I haven’t tried the first plugin tutorial in a while, but i was getting the Grasshopper components to work.

Did you restart once you added the Rhino Common adding like it says in the Dev Docs?

My addins, I did this quite a while ago, but I believe searching for ETO like Rhino above will add it.

I don’t have any other explanation, that doing a direct Tamarin download and then the Rhino adding then Eto.

Bonne chance !

«Randy


#3

Runs fine here,

Maybe just download Tamarin again. I didn’t see any options to get any other versions …

«Randy


(Dale Fugier) #4

Hi Pierre,

What version of Rhino for Mac are you running?

You will need version 5.1 or greater…

http://developer.rhino3d.com/guides/rhinocommon/installing_tools_mac/


#5

Hello Dale,

I am using the current WIP version 5.2.1 because I am planning to practice developing for Grasshopper.

Thanks !


#6

Hello Gregory !

Thank you very much for your help !!

I still get “RhinoCommon assembly not found for framework Mono / .Net 4.5” in the “References” folder.

I am indeed using Xamarin Studio 6.1.1.17. I also tried the same version as yours: 6.1.1.15.
By the way, previous versions can be downloaded from here:
https://store.xamarin.com/account/my/subscription/downloads

I installed “RhinoCommon Plugin Support 2.3.0.6” directly from the Add-in Manager.
http://developer.rhino3d.com/guides/rhinocommon/installing_tools_mac/

It seems Eto, Rhino.UI and RhinoCommon are not loaded. Should they all be located in /Library/Frameworks/Mono.framework ? There is nothing there.

Have a nice day !


(Dale Fugier) #7

No, there are in the Rhino package…


#8

Thank you !

Thanks to your information, I found out I needed to provide a path to ETO, Rhino.UI and RhinoCommon:
http://developer.rhino3d.com/guides/rhinocommon/debug_rhinowip_mac/

I indeed moved my apps in a subfolder of Applications. I then need to give a path to dll located within RhinoWIP or Rhino.

Now paths given in the .csproj file does not seem to work. I tried:
-> to move RhinoWIP.app or Rhino.app in the /Applications folder
-> the syntax ..\..\Applications\Graphix\RhinoWIP.app\Contents\Resources\RhinoCommon.dll
->the syntax \Applications\Graphix\RhinoWIP.app\Contents\Resources\RhinoCommon.dll
->the syntax /Applications/Graphix/RhinoWIP.app/Contents/Resources/RhinoCommon.dll

“Xamarin Studio.app” is in the /Application folder and my .csproj file located in the “Projects” folder in my home directory.


(Dale Fugier) #9

@dan, can you look into this?


#10

Âllo @Pierre_Duduche , I am here at work, in a bit I will do a clean install of Xamarin on my Mac running macOS 10.12.1, Xamarin is not installed here. Maybe I can see if i get the same error.

I was using it at home to do some Grasshopper plugins also!

I will keep you updated with screenshots!

«Randy


#11

Thank you very much !!
There is NO emergency at all. I have plenty of time with that since I am also working on many other things.


#12

I have this for the ETO, Rhino.UI and RhinoCommon assemblies.


#13

It seems to be taking a while, here is the Mono install …

I am here for another hour. My Mac at home was having issues with a new SSD drive I installed and cloned my old OS from. I will see if it is doing OK once back home.

It just seems odd, it seems my install went so smooth before.

Have you tried installing ETO the same way for the Rhino.Common plugin? I believe this is how I did it before. Or it may have to be added separate from Rhino. I have no app here so just talking from memory.

Bonne chance !


(Will Pearson) #14

@dan, absolute paths seem to work fine w.r.t. finding the references. Hmmm

...
<Reference Include="RhinoCommon">
 <HintPath>\Applications\SubFolder\RhinoWIP.app\Contents\Resources\RhinoCommon.dll</HintPath>
</Reference>
...

#15

Hello !

I am away for a day.
Let me just tell my I did not install Xamarin.Android, Xamarin.iOS and Android SDK. This should not make any change though.
I will tomorrow re-install Xamarin. This may remove what I did wrong.

Have a nice day !

Bonne chance !
< Merci ! :wink:


#16

I will let you know how it goes. I am also doing a clean install of OSX on my home computer right now. So I will be installing Xamarin here again as well, not today though.

Merci et bonne journée :relaxed:

«Randy


#17

Âllo @Pierre_Duduche ,I had to add Eto & Rhino common through Add-In Manager / Gallery …

Try to see if that works before doing another install of Xamarin .

«Randy


(Dale Fugier) #18

Hi Pierre,

I believe the problems you are having are due to the fact that you did not install Rhino into the Applications folder, or move Rhino to a different folder after installation.

Also, you don’t need to install Eto.Forms, through Xamarin’s Add-In Manager, because Rhino comes with the required Eto assemblies. You only need the Eto.Forms add-on if you plan on writing a standalone application that uses Eto.

– Dale


#19

Thanks Dale!


#20

HELLO !!

My problem is solved !
I got it working by installing Rhino to /Applications/. I un-install the “RhinoCommon Plugin Support”, re-install it and re-made a RhinoCommon Plug-in project.
I will later have a closer look at what happened and will better clarify it here.

Thank you very much Randy and Dale !!!