Rhinoceros wants to make changed

Hello, I have been trying to run the rhinoceros 90 day free trial and I always stumble with the same problem. After writing out the license key (which is correct) a window appears saying “rhinoceros wants to make changes” and asks me to enter my username and password. I have tried dozens of times, and it just says its wrong every time. I am absolutely certain that the password is right, I’ve even changed it twice and neither work.
I tried opening and closing the application, I uninstalled it and then installed it again with another email and nothing works.
Without entering my username and password it doesn’t let me save my progress in the application, I don’t know what to do at this point.

Is there something I can do or someone I can call to fix this issue? If someone had any insight please let me know.

if the dialog box has a lock icon on it, that is your machine asking for you MAC password… the one you use to log into your machine when you start it. This is an operating system password ask, not a rhino password ask.