Rhino7: Osnap decreases performance

I am experiencing something new, with Rhino 7 that I’ve not seen before.

When using PolylineOnMesh to draw annotations on models (which I’ve done quite a lot), I am seeing Osnap increase the strain on my CPU 10-fold (from 2% to 20% in the Performance tab in Windows Task Manager). However, it only triggers when the “End” or “Mid” options are ticked on for Osnap - the other options do not trigger this same effect.

Both Mid and End are options that make my workflow considerable easier, so this weird increase and the resulting lagging performance and responsiveness of Rhino is… well, irritating, if I’m being honest.

Has anyone else experienced this?

P.S. I am seeing it happen in all types of viewports and both in Shaded and Rendered display mode (I haven’t tested the others).

Hello - thanks, I see this non-responsiveness as well in PolylineOnMesh. I’ll see if we can make that better. It seems pretty notchy in 6 as well.


Thanks for the quick response! I know its only been out a few weeks, but I’m hoping minor tweaks and updates are on the horizon? I’m curious as to why it seems to only be some parts/options of Osnap that trigger the decreased performance. It’s certainly possible that polygon density of the models I’m working on play a role in it. The mesh has a highly detailed surface area, so I reckon the calculations run by the tool are increased there to. Just weird it doesn’t trigger when I disable Osnap. “Free hand” PolylineOnMesh works without a hitch.

I never got to use v6, but jumped from v5 to v7, so I can’t attest to v6 performance. But thanks for letting me know that I’m not alone in experiencing it :slight_smile: .