Rhino7 crashes on second dxf export

Hello there,

i encounter a strange behaviour in my Rhino 7.
Each time i try to export a dxf for the second time, Rhino crashes hard.
It does not matter which curve i try to export.
Let´s say i have a document with 2 curves: I export curve 1 as dxf and get no problem. I try to export curve 2 and get a hard crash. No error message, just freezing my PC.
When i restart Rhino and export curve 2, everything works. But then curve 1 crashes Rhino and so on.
I tried it on several PCs from Laptop over older Desktop to new Desktop and with several different files… Everytime the same behaviour. A second dxf export without restarting Rhino causes a freeze and hard crash.

Here are the specs one one of the PCs. Maybe it helps.

Rhino 7 SR9 2021-8-10 (Rhino 7, 7.9.21222.15001, Git hash:master @ 190335c3fb65efe86c302714a8959a7dadfe667b)
License type: Kommerziell, Build 2021-08-10
License details: Cloud Zoo

Windows 10.0.19043 SR0.0 or greater (Physical RAM: 16Gb)

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: AMD Radeon ™ R7 360 Series (AMD) Memory: 2GB, Driver date: 11-4-2020 (M-D-Y). OpenGL Ver: 4.6.14736 Compatibility Profile Context 20.11.1 27.20.12033.2007

Accelerated graphics device with 8 adapter port(s)

  • Windows Main Display attached to adapter port 0
  • Secondary monitor attached to adapter port 1
  • Secondary monitor attached to adapter port #2

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: ATI Technologies Inc.
Render version: 4.6
Shading Language: 4.60
Driver Date: 11-4-2020
Driver Version: 27.20.12033.2007
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 2 GB

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.9.21222.15001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 7\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.9.21222.15001
C:\Program Files\Rhino 7\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.9.21222.15001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.9.21222.15001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.9.21222.15001
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

I hope you can help me

Hi -

I’m not seeing that here so far.
Could you update to the current 7.10 version and see if that still behaves the same way?
If so, please post a 3dm file that I can use to try to reproduce this. Also post the settings that you are using in the DXF export.
Finally,

A freeze is not the same as a crash. If you can reproduce the freeze in the current version, please follow the instructions in this page: Manually Creating a Memory Dump (DMP File) from an Unresponsive Rhino for Windows [McNeel Wiki]
Thanks,
-wim

I updated and still the same problem.
For a .3dm file just use any file with 2 curves. For testing i just added 2 lines in an empty file.
I export by marking 1 curve and use the export selected command and selecting dxf as type.
Here is a picture of my export settings.


Further i created the dump file and uploaded it with your update system using this thread as description.
Hope that helps :slight_smile: