Rhino7 crash on loading docstrings of build-in funtion in GHpython


I’m using Macbook with M1 chip. My rhino 7.0 constantly crashes when I use type(), len() (same build-in functions)… in GHpython. it seems to have trouble loading the docstrings, as it crashes when I try to type “(” right after the commend. Rhino 8.0 WIP doesn’t have this issue. I attached the full report.

Rhino 7.0 Crash Report.pdf (94.7 KB)

Hey @user2234,

Thanks for reporting the issue! This was already reported as RH-65457, and should be fixed in 7.16 when it comes out. You can give it a try here, but be aware this a pre-release version so there may be other issues.

Please let me know if this solves the crashing issue.

1 Like

Hey Curtis,

it solves the issue, not crash anymore. Thank you!


1 Like

Hi Curtis,

There is one issue with this new version, unfortunately. in the 7.14 I was able to load COMPAS from GH python without an issue. But with this 7.16 version, it keep saying module named numpy’ please see the attached image. I re-install the Compas-rhino, it still shows the same error.

Hey @user2234,

Thanks for giving it a try and reporting the issue! I’ve created RH-67339 to get that fixed up.

Thanks a lot!

Hey @user2234,

After some investigation, the problem with COMPAS is that it does not correctly detect IronPython >= 2.6.10 which I have reported to the compas repo here. Hopefully they can issue a fix which will get this working again with Rhino 7.16

Note that this also uncovered a problem with our shipped IronPython standard library which reported the incorrect string for platform.python_implementation(), which will be fixed in the next Rhino 7.16 SRC.

RH-67339 is fixed in Rhino 7 Service Release 16

Same issue in Rhino 6. Trying to follow this video (Learn Python for Grasshopper - Full Course for Beginners - Free - YouTube) and learn some python scripting and type the following:

import rhinoscriptsyntax as rs
import System.Drawing as sd
import Rhino.Geometry as rg
from Grasshopper.Kernel import GH_RuntimeMessageLevel as rml

geo =
colors =

if type(eX…

As soon as I hit the first parenthesis in front of “eX” Rhino crashes and quits within a blink of an eye. I can copy paste the above and type as many paranthesis as I want. But as soon as I delete the one in front of eX and type it Grasshopper and Rhino crash.

Version 6 (6.35.21222.17002, 2021-08-10) on MacPro Late 2013

Hi Bo -

We are no longer fixing any issues in Rhino 6 at this point. Crash bugs still get fixed for Rhino 7 but apart from that, all bug fixes will go into Rhino 8.