Rhino6 Visual Bug; Layers Panel is Blank, Unable to Select Layers

Hi there, if someone could help me troubleshoot this issue it would be greatly appreciated.

I am using Rhino6. The problem is that my Layers panel has suddenly gone blank. I was working earlier today with no issues, but when I came back to my work I found that my layers panel was blank.

These are my findings so far:

  • I tried resizing the panel and dragging the panel to my second monitor but it was still blank on my second monitor.

  • My layers and objects all still exist in my file. I know this because I can see my layers in the Properties panel, and I can select an object and change it to another layer using the dropdown menu.

  • My Layers panel is blank when I am in model space (Perspective/Top/Front/Right, all of these model space tabs show blank Layers panel). I am unable to right-click or double-click in the blank space to change my current layer.

  • My Layers panel is visible when I am in my print layout tab.

  • I am unsure if this is a hardware problem or a Rhino6 problem. I have uninstalled and reinstalled Rhino6, but the blank layer panel persists.

  • I downsaved my project file to Rhino5 and my file was still intact and my layers panel appeared normally.

If someone has any solution or any idea where to begin fixing this, I am in desperate need of help! Thank you in advance!

Hi @trumon.tse

That’s indeed really enjoying.

Here’s an old thread describing a similar problem… seems to rely on the display driver in that case …

Rodolfo Santos

Hi -

The fact that they show up fine for a layout makes me believe that all columns somehow got turned off.
If you right-click close to the top, right below the toolbar buttons, you should get a pop-up with the column names. Are they all unchecked like in this image:

If so, just turn them back on one-by-one by clicking on the column names.

Thank you so much Wim! That was the solution! I’m feeling a little silly because the solution was as simple as a mouse click.

Also I believe you meant “right-click close to the top”, I was left-clicking but no menus were appearing until I tried right-clicking.

I’m confused as to how that happened in the first place. I’ve never that used that function before in my many years of using Rhino. Do you know if there was some accidental keyboard shortcut or command that caused this?

Hi Trumon -
Sorry for the confusion, you are right, it was “the other left button” - I’ll change that in my original reply in case someone only reads that.

No, and I don’t recall having come across this before. Please keep an eye on it and let us know if it happens again.