Rhino6 purchased version issues


(Lentakffm) #1

hi there,

i was under the assumption that once it’s offered for sale, rhino6 should be stable enough for production use out of the box. that’s why i went ahead and bought it.

but right out of the gate, i ran into some issues that forced me to go back to using v5 again, namely (in no particular order):

  1. a few of my favorite grasshopper plugins loading, but throwing errors (e.g. mesh+) such as “specified cast not valid, line so and so”.
    i do understand, though, that this is a more of an appeal to the very generous plugin developers, rather than mcneel as such

  2. upon switching to rendered mode, the viewport turns completely black. i managed to figure out that switching off skylight makes it come back, but only as long as the objects aren’t assigned any material with even the slightest amount of reflection, in which case it goes back again.

  3. arctic viewport is black no matter what

  4. with Osnap turned, in rhino6 i see the crosshair and a box callout informing me what i am snapping to, but i don’t see the little square dot in the middle of the crosshairs showing the precise snap location as in v5. which makes it very difficult visually to see if i am on target.

i have tried to look for a setting to enable the dot, but failed to find it.

thanks

l


(John Brock) #2

Items 2, 3, and 4 all are symptoms of buggy display drivers.
See if installing an updated driver fixes those problems.

Item #1 should be directed to the developer of the Grasshopper plug-in.
During the V6 development phase, we worked with users and developers to get them compatible.
It sounds like you may have found one that slipped through the cracks.


(Steve Baer) #3

We may be able to tune Rhino up to make these grasshopper components work. Could you provide a list of the components that are causing problems?

As JB mentioned, the other problems are display driver related. Go to the help menu and select “System Information…”. Copy and paste that information into this thread. We may be able to use that information to help diagnose what is happening.


(Lentakffm) #4

hi guys,

thanks for getting back so fast on a sunday evening. greetings to your respective wives…

i will see about updating the driver, but for now the system info says:

Windows 7 SP1 (Physical RAM: 12Gb)

GeForce GTX 285/PCI/SSE2 (OpenGL ver:3.3.0)

OpenGL Settings
_ Safe mode: Off_
_ Use accelerated hardware modes: On_
_ Redraw scene when viewports are exposed: On_
_ _
_ Anti-alias mode: 4x_
_ Mip Map Filtering: Linear_
_ Anisotropic Filtering Mode: Height_
_ _
_ Vendor Name: NVIDIA Corporation_
_ Render version: 3.3_
_ Shading Language: 3.30 NVIDIA via Cg compiler_
_ Driver Date: 7-9-2010_
_ Driver Version: 8.17.12.5896_
_ Maximum Texture size: 8192 x 8192_
_ Z-Buffer depth: 24 bits_
_ Maximum Viewport size: 8192 x 8192_
_ Total Video Memory: 1 GB_

regarding the GH components, thanks for the offer, i realize it means going out your way. i need to put v6 to some more use to see which one do/don’t work.

but meanwhile, e.g. mesh+ frame+0 throws a “1. Specified cast is not valid. (line: 252)” error. which would be: txv(0) = mN(xv(y(k))) * evalN(D(xv(y(k))) * t0(xv(y(k))), xd * xn, N(xv(y(k))))

all chinese to me, unfortunately…

regards

l


(John Brock) #5

That may win for oldest display driver I’ve ever seen in Windows 7.
When you install the new one, click on the Advanced option button and check the box for doing a “clean install”.


#6

Get new NVIDIA driver from: http://www.nvidia.com/Download/index.aspx?lang=en-us
Go to Device Manager and update Intel graphics driver, as shown below.
intel%20graphics%20driver

If you drive a car, you must have insurance, and you must change oil twice a year. If you use a computer, you must have good anti-virus program, and you must update drivers twice a year.


(Lentakffm) #7

only if one’s a geek i guess, for mere mortals like me it’s “if it ain’t broke, don’t fix it…”.

good tip with the oil, though. seems i gotta have a word with the mechanic one of these days, car’s going on 8 years now;)

thanks for the driver link

t


(Lentakffm) #8

just a quick followup, gentlemen.

as you suggested, dutifully updating the driver to a 2015 version did sort out all of the display issues.

the rendered mode with skylight and shadows ON is borderline torture, though, given the lags with just a single object (sphere) showing. even clicking the box to turn off shadows takes 3-5 seconds to register the click…

until now, i actually thought my system was beefy enough for my kind of simplistic models (i7, 12gb ram, 1gb graphics, ssd). now it seems i’d at least need to replace the graphics.

could you please recommend one that tested positive for rhino6 perfomance and doesn’t cost an arm and a leg (say in the region of 300-400 euros)?

thanks

p.s. if there is a wishlist for the next service release, i would join the chorus asking for thinner edges (rhino5 style). using the secret …testwirethickness command didn’t do much for me even with thickness set to 0.1.

with antialiasing turned off (following the driver update), i almost panicked thinking i was thrown back in time to the 80s arcade games resolution - lines and edges looked like carved with an axe. changing AA to 8x made it okay, but i wonder what the performance cost is…


#9

Don’t forget to set the command line option to Enabled=On - otherwise you won’t see any change at all…


(Lentakffm) #10

thanks, but that i did. even though, granted, i did overlook the toggle at first.

i do see changes, but very minor ones. the difference b/w a 1.0 and 0.1 setting is maybe 20% less thickness, if that.

we try again when i’m at the PC.