Rhino6 MAC WIP: unable to enter licence key on MACOS Mojave

rhinoformac

#1

the dialog for entering your licence key is not working under Mojave. looks mostly blank (see attached screenshot). I should also say installing and entering licence key for RH5 for Mac worked fine. its only the WIP that has an issue.


Rhino 6 for Mac WIP build 6.12.18317.12076
#2

I reported this here as part of a much bigger problem: Crashing while sleeping


#3

Third confirmation to back up Ben4 & RobinP’s experience.

2012 Macbook Pro Retina with OSX Mojave 10.14.1


The first dialog box, I figured was asking for the License code itself. Clicking into the text box doesn’t reaffirm with the expected blinking cursor. Nevertheless I typed out that code in another app, copied, then pasted into the WIP License box where it CONTINUED to show nothing… however, if I scrub my mouse in the blank box, the pasted code can be seen until I lift the mouse button. Continuing into the following page, there seems to be numerous hidden blank boxes, but without knowing what specific info is wanted, I’m effectively halted.

All I can do for now is to back out of it with the Skip Registration and select Ask Me Later

I’m hoping the Rhino System Info I’ve emailed to support is helpful.


(John Brock) #5

I just talked with one of the Developers.
Please try this:
Switch from Dark mode to Light mode.
We think Rhino is drawing white text on a white background.
Please let us know if this work-around works.
Then you should be able to switch back to dark mode.

Any luck?


(Dan Belcher) #6

Logged as RH-49395 as I’m 90% certain this conjecture about Dark Mode and white text is what is happening.


#7

Great sleuthing John & Dan.

Toggled out of Dark Mode back to Light Mode and the dialog box was legible once again. Filled the info out and finally got validated.

You’ll note that while I’m in Light Mode, the originating box behind it where the License number should be is now black. Scrubbing my mouse over it reveals that numbers are actually displayed.

At this point, when I go back into System Preferences > General > Appearance and toggle it once more into Mojave’s default Dark Mode, that License box displays properly.

Thanks guys.


(Dan Belcher) #8

Thanks again for reporting this. It will be fixed in the next RhinoWIP.


(Dan Belcher) #10

…and fixed! You should now be able to license Rhino from the Dark side in the latest RhinoWIP.