Rhino6/Grasshopper+VisualARQ2.1=Many errors

Overall, I am enjoying the new ViaualARQ however, I have a similar experience with VisualARQ crashing Rhino 6. I do not have, nor have had V-Ray installed. I do have Brazil and Bongo plugins as well as several grasshopper plugins. When starting Rhino, a list of grasshopper errors will appear (see attached txt file), several of which name the Clipper Components plugin as having some issue. The Clipper Components plugin will not properly load despite several uninstall/reinstall attempts.

GH_Load_Ex.txt (3.7 KB)

Running Rhino 6 with VisualARQ does feel slightly more sluggish than running Rhino without the plugin. Rhino also appears slower in updating the graphics of ViaualARQ components and misses some objects while in shaded mode. Technical mode appears to work fine.

Hi @Elshar and @jperick1 ,

I’ve found and fixed the bug!

Here is an explanation about the bug:

And here is the installer for the latest WIP build of VisualARQ 2.1.1:

Please, test it and let me know if you still see errors when loading VisualARQ or Grasshopper. My plan is to publish it later today if there are no issues.

Thanks again for your patience and your help!


1 Like

Hi! I dont know, if this is relevant comment here, but I have just noticed a display error in rendered (and others) display views using skylight and shadows. There are some shadow fragments when using clipping plane. This happens only with VisualARQ loaded to Rhino 6. See picture bellow.

Hi Enric,
I have downloaded and tried the WIP version, and it works pretty fine. No errors appeared when loading VisualARQ nor Grasshopper. And it appears to be slightly faster in Rhino 6 than the 21.0 version.

As @petumatr mentioned above, I don’t have the shadow fragments when using clipping plane, but I do noticed that VisualARQ objects appears to have some issues when using clipping plane in some display modes:
-Raytraced display mode: Clipping Plane ignores all VisualARQ objects.

Arcitic Display mode: Clipping plane does cutting through the VA Objects, but it ignores some.

Rendered & Hidden Display modes: Clipping plane does cutting VA Objects but it appears to be like a mirror I don’t know.

The other display mode are just working fine displaying the cutting objects.

Just a quick note on Raytraced, that display mode doesn’t support clipping planes as of yet.


VisualARQ 2.1.1 has just been released:

These display issues on rendered display modes when a Rhino clipping plane is enabled are fixed. Raytraces display mode still has some problem with VisualARQ. We’ll try to fix them for the next update.

Let me know if any of you have problems with this new release.



1 Like

Hi Enric,
These screen shots above are generated within the VisualARQ 2.1.1

I think you’re using a pre-release 2.1.1, as I’ve fixed this bug 3 hous ago and I haven’t publish any version after that…

Can you please download the final 2.1.1 and try again?



I used this one.

I will download the one you posted recently.

Some issues I’ve already experienced:

  1. Rhino crashes every time I try to extend walls causing a connection / splitting walls at T-shaped connection.
  2. Spaces in hidden view are unselectable
  3. If I save file in Rhino 6 with VA objects to Rhino 5 format I cannon open It in RH 5
  4. VA object’s properties panel has 2 parallel scrollbars when they do not fit in available space on screen and they seem not to work correctly

Hi @Tomek_Wloga,

I’ve tried to exend a wall until it reach another wall resulting in a T connection without a crash. Can you send me a sample model and the steps to reproduce the crash?

I tried also to create 4 walls and a space in a hidden viewport, and I can select the space without problems. Can you send me also a model where your’re seeing this issue?

Again, I tried to save the model with the 4 walls and the space in Rhino 6 using a Rhino 5 format, and I have been able to open it in Rhino 5 with VisualARQ 2.1. Are you using VisualARQ 2.1 in Rhino 5? VisualARQ 2.0 cannot open files from VisualARQ 2.1.

I’m unable to reproduce this issue. Can you send me an screenshot?



The file was already sent by email.

I also experience the Rhino 6 crashing every time I print to PDF with vectors.

Hi @Tomek_Wloga,

Which PDF printer are you using? We’ve been using here the “Microsoft to PDF” and “CutePDF” without problems. Using the “Rhino PDF” we’ve just discovered that some objects are not visible (specially texts) and we’re currently investigating why.

Is the crash happening all the times? Or only when trying to print some specific models?



When I use Bullzip PDF printer it works ok, but it crashes when using Rhino PDF.
I’ll send you the model via e-mail.

Enric −
The v2.1.1 update to VA appears to have fixed several of the earlier crashes I was experiencing, thank you! Now I have a new bug to report which is a more consistent crash. A specific model (or any VA file with the slightest complexity) causes Rhino to crash either when opening or within moments of opening. The file can be opened and worked on when VA is not enabled; all views are set to wireframe; and tried deleting the last few VA objects added to the file but a crash is inevitable.

I have sent a plethora of crash reports to McNeel (under my user name) over the past two days that are related to this crash.


@jperick1 Can you send that model to visualarq@asuni.com so we can check it out?

Hi @jperick1,

I think that the this problem is already solved in VisualARQ 2.1.2, which is not yet released. Here is the download link for the latest WIP build:

Please, try it and let me know if it still crashes.



After installing the 2.1.2 WIP update, the consistent crashes have been alleviated. I appreciate how responsive VisualARQ team is at correcting these issues.



Hi guys, I have the latest release, I don’t seem to be getting any fills shown on my sectioned geometry in 3d (whether VA or Rhino) in any display mode, Geometry seems to be empty even if Show Fills is ticked in display options and geometry section attributes are correct, any ideas?Line types etc don’t show either. They all do show when creating a section view though. Same exact geometry and settings appears as “solid” in R5. Thanks!

Note: Cuts seem to work fine on plan (Level View active) and they even work in section when both section and level are activated, but not when only section is active. Current workaround is to have a level above all geometry and keep it active in 3d view.