Rhino WIP rendering?

Not sure if this is a WIP issue or a me issue, but the same document renders black in WIP and correctly in Rhino 5. I used the same render settings for both. Running 6.0.17283.9031, 10/10/2017. Any ideas on what could be causing this?

Seems it’s on the bug list.
Is it the same problem?

I don’t think so… I was just trying to do a clay rendering

I just tried the 10/10/2017

Using Rhino Render and the Objects are flipped upside down and Skylight setting is set to off,
I was able to make a black render.
Not sure if that’s the case…

Nope, that’s not the problem.
with the skylight and the sun on. The INTERIOR 2 view (currently shown on screen renders as the Unamed-01 image (black)

when done in rhino 5, it renders correctly

I couldn’t reproduce it, but when making just few boxes and couple of
lighting like directional/spot/linear and having skylight sun-light on
inV5, then save and opened in WIP to render and WIP crashed…
Sorry couldn’t help…

@k11, can you please attach a file that shows this problem for you?

thanks for giving it a shot @Toshiaki_Takano

@nathanletwory The file is too big; how should I send it?

@k11, you can use rhino3d.com/upload to send it to us. Be sure to copy the link to this discussion (Rhino WIP rendering?). You can put in the recipients field nathan@mcneel.com and I’ll have a look.

@nathanletwory Just sent! Thanks for your help!

@k11, thanks. I see the file.

I’ll have to ask @andy about the differences between Rhino Render v5 and Rhino Render in WIP regarding skylighting. Your initial view is inside the building that has no openings for light whatsoever. Logically that means no light can get in, and I suspect that Rhino Render in WIP has had changes that essentially have it obey such blockage (but again, I’ll have to ask @andy to be sure).

If you switch to Raytraced view (which builds upon the Cycles engine from Blender 3D) you’ll see the same blackness. You’ll have to create openings for light to get in, or place lights inside the building.(And if you are playing with Raytraced for your scene specifically - once there are openings for lights, you may want to increase the diffuse bounce count in Tools > Options > Cycles to something larger than zero. Higher numbers means more diffuse bounces (light bounces further, lights more).

edit: confirmed - skylighting is in Rhino Render of Rhino WIP now also more physically correct. So rendering from inside a fully closed box without lights isn’t going to work well.


@nathanletwory Oh, gotcha! Thanks for the help! Yeah, I just tried to render an outside view and it works fine.