Rhino windows inactive - interface and viewport very slow

unhandled

(Brice Launay) #1

Hi

I try to work with rhino 6 but regularly the window becomes inactive. Sometimes when I’m using a command or I’m moving in the model and even without any action on the keyboard or mouse, it becomes inactive. The title bar turns gray as if the window was moving in the background. After that the interface effects are slowed down (drop-down menu, activation of the icons on flyover, …) and visualization, rotation, pan and zoom are very very slow.

Everything becomes normal after a few minutes

My config:
AMD threadripper 1950X
32 GB RAM
GTX 1060
SSD
RHINO 6 (demo 6.4.18124.12321)
VRAY 3.6 (monthly subscription)


(Nathan 'jesterKing' Letwory) #2

Can you try disabling (load-protecting) V-Ray, restart Rhino and see if that improves Rhino UI?

Please post the contents of Help \Rightarrow System\;Information as well.


(Brice Launay) #3

Here the system information :

Rhino 6 SR4 2018-5-4 (Rhino 6, 6.4.18124.12321, Git hash:master @ 396f4c3420cadef29ac36e4307c8f98f7753c933)
Licence type: Evaluation, build 2018-05-04
License details: Stand-Alone
Expires on: 2018-07-23

Windows 10.0 SR0.0 or greater (Physical RAM: 32Gb)
Machine name: DESKTOP-O6M7ND4

GeForce GTX 1060 6GB/PCIe/SSE2 (OpenGL ver:4.6.0 NVIDIA 397.64)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 5-7-2018
Driver Version: 24.21.13.9764
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 6 GB

C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI”
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros 6\BatchRender.rhp “V-Ray Batch Render”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles”
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars”
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros 6\VRayForRhino.rhp “V-Ray for Rhino”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”


(Brice Launay) #4

I’ve turned off vray plugin (load protecting disabled).
I will try to work like this to see if it happens again.


(Brice Launay) #5

As soon as I disabled vray, everything seems much more fluid (rotation zoom pan) and no problem with the interface. When enable load protection, the bugs are back.

An idea of what can I do ?

Thanks for your help


(Nathan 'jesterKing' Letwory) #6

In the very least report this to Chaos Group.