Rhino V5 & V6 not recognizing Nvidia 1080 ti

display
rhino5
unhandled

#1

Long time Rhino user here, first time posting. I manage several machines with Rhino licenses for our lab here at MIT.

I’m writing because our lab render computer, currently running two Nvidia 1080 ti cards, is not being recognized by Rhino and we’re stuck with the generic windows driver. This has consequences for functionality and performance (PictureFrame is a casualty), and it seems like a problem that seems to come up from time to time by other folks here on the forums. The general answer always seems to be “update video driver.”

We’ve downloaded and updated our video driver manually, using Nvidia’s latest WHQL driver (see screenshot attached). Rhino is still not recognizing our cards. Same result in V6.

Ironically this is not a problem with the cycles renderer, which is identifying the two graphics cards.

Can anyone from McNeel or here on the forums point out what the problem is? I’ve seen others on this forum who seem to have working 1080’s, but can’t determine why Rhino is not working properly on our end.

Thanks

Will

driver


#2

Your 6800k can only run SLI in 8x speed. It doesn’t have enough PCI-e (28) lanes for x16. The 6850k has 40 lanes.


#3

Hi Stratosfear,

Thanks for the input. This is definitely something to keep in mind (though we’re not using the cards in SLI, sometimes our lab has to split use of the cards).

Do you think this would keep the cards from being recognized by Rhino?

Thanks again!


#4

Perhaps @jeff or @stevebaer might be able to help here.


#5

I know Pascal based (1000 series) cards don’t work well with Rhino 5. My understanding is that Rhino 6 has been designed to work with them going forward.

In your case it may be struggling to recognize which card to use.


#6

Surely it would only get confused which to use if both were connected to a monitor?

If this is a gpu render slave (sand SLI) that’s probably not the case…


#7

Great thoughts, based on these comments I’ll try two solutions:

  • Try the cards in SLI configuration
  • Remove one card

I’ll give both of these options a shot and report back on if Rhino 6 is recognizing them.

W


#8

Wow the latter worked. Soooooooo silky… can’t handle … 8x antialiasing …

Rhino v6 is showing Nvidia drivers in the properties panel.

I’ll order a cable to try SLI next week.

Thanks for the help! This forum is amazing.


#9

Most motherboards toss in couple SLI bridges.


(Jeff Lasor) #10

The fact that Rhino doesn’t see it at all says that there’s something going wrong between Rhino and the driver.

Have you tried installing V6 and see what it does? I would be very curious if V6 did the same thing.

Meanwhile, let me think about this for a bit and I’ll get back to you.

Thanks,
-Jeff


#12

Hi seems to tested V6 as well.


(Jeff Lasor) #13

Thanks, I guess I missed that…

Well, that makes this one even stranger then… V6 initializes and sets up OpenGL in a completely different way than V5 does…which means two different applications failing to setup an accelerated OpenGL context.

I’m going to need to throw something together that you can run on your end that hopefully will help diagnose this better.

@Will_Walker Do you have any other OpenGL based applications on your computer that you can verify/confirm are working correctly?

Hopefully will have something for you by Monday.

Thanks,
-Jeff


#14

Thanks for the feedback, Jeff.

Both V5 & V6 could not identify the two graphics cards when they were running in parallel within our box (we use them that way occasionally to run multiple, intensive tasks like ML etc. Even with the latest driver installed. Cycles rendering was able to identify the dual card setup.

Once I removed one of the two graphics cards, both V5 and V6 were able to identify the card and performance noticeably improved.

Next step is to get a SLI bridge and see if they will register with rhino in SLI mode. I was sure we had a cable around the lab but recent fall cleaning might have gotten the better of us, so it will have to wait until next week.


(Jeff Lasor) #15

Hi @Will_Walker, it’s starting to sound like what you’ve done (or are doing) is configuring your system so that your cards are “compute” driven, and that there is no “Primary Display Adapter” configured… Without a primary display adapter, Rhino will not be able to initialize any OpenGL subsystem. Cycles sees them because it enumerates and uses video cards in a completely different way (as computational entities).

That being said, I’m not sure what Rhino (I) can do about that in this type of situation…but I will look further into it. Setting up SLI should still work with Rhino, because one of the cards will still be a primary adapter, and the other will simply be SLI’d to it.

If you could, please provide me with exactly what you’ve configured, and how you’ve configured your two cards in parallel… I want to make sure that when I start looking into this, that we’re using the same settings.

Thanks,
-Jeff

P.S. Over the years I have acquired dozens of SLI bridges :slight_smile: … in fact, they fill an entire drawer here.


#16

Throw those SLI bridges my way :smiley:

We’re mainly really happy we can just get a single one working. The difference in performance is amazing, it’s really a joy to work with now.

In terms of our previous, my guess is that we didn’t set a single card as the primary display driver, and it makes sense that it wouldn’t work. Other programs that were graphics driven seemed to have some slight errors that are much more functional with a single card installed. When I get a chance next week, I will download and run blender and see if I can replicate the problem (Blender also runs on OpenGL). If it does we can close this problem and recommend that people make sure there is a primary card - running cards in parallel is now a much more common thing with cryptocurrency mining being a second use case during off hours.

In terms of our configuration

Again, thanks for the quick and thorough response. With your help we’ve boosted our Holomark score significantly (up to 53k from 30k before).


#17

A long overdue update to this story -

The SLI bridge came in and after installation, Rhino 6 has no problem recognizing 2 Nvidia 1080 Ti cards in SLI configuration.

I haven’t checked on parallel performance in the past 4 months or so; can’t really say if this is still an issue or not.

Still, performance has been great, particularly rendering using Cycles.


(Nathan 'jesterKing' Letwory) #18

Yay :slight_smile: