Rhino V5 (64-bit) reports "Bad image" and won't start

(John Brock) #1

Revised 9/14/17 - May be caused by McAfee…

A small percentage of users are reporting that after a recent update, Rhino V5 64-bit will not start. Our original guess was this was caused by an unknown Windows update. Now there are indications that this may be caused by McAfee anti-virus instead.

Windows pops up a message like this about a damaged file:

The fix is pretty easy.
In Windows’ Control Panel

  1. Run the Programs and Feature tool
  2. Find "Rhinoceros V5 (64-bit) on the list
  3. Select it, and choose the “Repair” tool

Please let us know what you find so we can pass along accurate information.


  • This error may come back after repairing and and successfully running Rhino again.
    If you find the error comes back, after repairing Rhino, try temporarily disabling McAfee and see if that stops it. You can also configure McAfee to exclude scrubbing the specific files or folders that are being damaged.

  • You may need to download the Rhino installer and run it if the Repair tool in Control Panel can’t find the MSI.

(John Brock) #2

(John Brock) #3

The mystery thickens…

Another user reported the 0xc0000020 error message. Repairing Rhino got him up and running but the next day Rhino would not start and reported the same error. Disabling McAfee apparently didn’t stop the error from repeating.

It turns out the user also had a copy of SolidWorks 2013 on his system. It would not start
either and reported a very similar damaged file error. He said this old SolidWorks version launched a few services at startup and he thought it might be related. He uninstalled SolidWorks 2013 and restarted his system.

Then after repairing Rhino again, the problem seems to be solved.
He thinks the problem was related to a service launched by SW 2013.

(John Brock) #4

Another possible work-around for this is after “Repairing” Rhino, go into the configuration tools for McAfee and exclude the damaged files or the folder they’re in from being scrubbed.