Rhino uses integrated video card instead dedicated

My laptop (lenowo x580) has 2 video cards: integrated and dedicated (gf 660m). Rhino should use GF but it uses integrated. Is there a way to make it use GF?
I have latest drivers for GF installed.

Hi Maciej,

Is ‘advanced hardware’ enabled in Options>Rhino Options>View>OpenGL?