Rhino to Romer Arm connection issues

I’m currently demoing Rhino to see if I can get it connected with a Romer Arm I am interested in purchasing. Unfortunately, I’m having some issues getting Rhino to recognize the arm (Romer Absolute Arm 7315). I have the newest version of RDS and of Rhino installed on my 32-bit Windows computer.
This is the error message I get in Rhino. Rhino cannot find the RDS program (the second window shows that RDS is up, running, and connected to the arm on this computer). I’ve tried unistalling and reinstalling RDS, but I continue to get the same error message. Any suggestions on how to proceed to get the two programs talking?

  • M

Take a look at this thread. It may be helpful.


I’m having the exact same problem. I’ve just performed a full reinstall of the latest versons of Rhino and RDS to no avail. Does anyone know how to solve this ?



Hi Alex - did you have a look at the thread linked a couple of messages up? Does that tell you anything? Can you get 32 bit Rhino to connect?


Yes I did have a look at that thread, but I was not able to get rhino 32-bit to connect.

I am running:
Windows 7
Rhino Version 5 SR11 32-Bit
RDS V4.0

My Romer arm is an absolute arm (RA7) and connects via USB.

@Tim do you have any advice about this? Do you need more info about my setup?

Thanks for your quick reply Pascal.

Hi All,

I looked at the source code for the plugin today. The message you’re getting happens when Rhino searches for this registry key, HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Uninstall\RDS, and can’t find it. That’s the location the Romer API guy told me to use for RDS 3.6 (looks like the current version is 4.X). I’m going to email him today and see if that location has changed. If it has then that’s the problem. When I know more I’ll post to this thread.


One other thing you could try in the meantime is running Rhino as an elevated user. While it’s not trying to change anything, it does need to determine if a registry key exists. I’m not sure what sort of user privileges are necessary to do that. I didn’t think you needed to be anybody special, maybe I was wrong.


Hey Tim,

I tried running Rhino ans RDS as an administrator and got the same error message. Thanks for looking into this!

It’s true, I have no Wow6432Node folder in HKEY_LOCAL_MACHINE\SOFTWARE

I do have:

Without the Wow6432Node… could that be the issue ?


I created a path using regedit to

I didn’t put anything in there but it seems to have solved the issue!

Thanks for your help Tim.