Rhino to MasterCAM, too many entity endpoints


#1

I am generating a 2D file in Rhino using text. When the file is opened in MasterCAM there are thousands of line segments. I have tried to view the endpoints in Rhino using F10 but when viewing in Rhino there are a normal amount of segments. How can I determine the number of segments and fix this problem? The end goal is to use this file on a CNC Wetjet.


(John Brock) #2

G-Code supports three movements:
Straight lines
Clockwise arcs
Anti-clockwise arcs

Any wiggly NURBS curve in Rhino that isn’t a line, a circle, or an arc needs to converted to arcs before being used for CAM.

Use the Convert command with the angle tolerance set to zero to disable it.
Use the command option tolerance to set how far you’ll allow the replacement arcs to pull away from your NURBS curves.
The dots in the preview will give you an idea of the number of arcs you’be be replacing your NURBS curves with.

Give that a go.


Micro controller/ CAD/CAM
(John Brock) #3

Mastercam may have a conversion tool for arc fitting too.
I’m not a Mastercam user.