Rhino taking forever to start

Recently (in the past week), it has sometimes taken 20 minutes to start Rhino. Happens just starting Rhino, or opening an existing file. It’s not limited to my computer, everyone in the office is having similar problems, and it’s happening from home as well.

Any ideas? It doesn’t seem to be tied to the last update… Problem with Zoo maybe?

Rhino 6 SR23 2020-2-24 (Rhino 6, 6.23.20055.13111, Git hash:master @ 8106edaa648ba209a8fc587f0f7fcccbaac09169)
License type: Commercial, build 2020-02-24
License details: Cloud Zoo. In use by: nate (Living Design Studios Design Team)

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: LDSDRAFTING13

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA GeForce GTX 1060 6GB (NVidia) Memory: 6GB, Driver date: 7-24-2019 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 431.70

Secondary graphics devices.
Intel® HD Graphics 630 (Intel) Memory: 1GB, Driver date: 12-10-2018 (M-D-Y).

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 7-24-2019
Driver Version: 26.21.14.3170
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 6 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\SolidTools.rhp “SolidTools”
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.23.20055.13111
C:\Program Files\Rhino 6\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 6\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 6\Plug-ins\RhinoBonusTools.rhp “Rhino Bonus Tools”
C:\Program Files\Rhino 6\Plug-ins\export_ACAD.rhp “AutoCAD file export : export_ACAD”
C:\Program Files\Rhino 6\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 6\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.23.20055.13111
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 6\Plug-ins\OptionsManager.rhp “Rhino Options Manager”
C:\Program Files\Rhino 6\Plug-ins\IronPython\RhinoDLR_Python.rhp “IronPython” 6.23.20055.13111
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.23.20055.13111
C:\Program Files\Rhino 6\Plug-ins\Grasshopper\GrasshopperPlugin.rhp “Grasshopper” 6.23.20055.13111
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.23.20055.13111
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\BlockEdit.rhp “BlockEdit” 6.23.20055.13111
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”
C:\Users\Nate\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\SectionTools (fbdb1d7f-8cfb-42c1-9858-87cb6315932c)\2019.2.19.478\SectionTools.rhp “SectionTools”

I suspect the problem is related to a Windows update that now requires updated display drivers.

Go to the graphics card maker’s Web sites and find updated drivers for your version of Windows and your specific models of display adapters.

DO NOT rely on the automatic checking tools as they have a near perfect failure rate.

Intel
(https://downloadcenter.intel.com/)

If your computer tells you the new driver isn’t validated for you computer, here’s how to fix that:
(https://www.howtogeek.com/343287/how-to-fix-the-driver-being-installed-is-not-validated-for-this-computer-on-intel-computers/)

nVidia
(https://www.nvidia.com/Download/index.aspx?lang=en-us)

Any luck?

Hmm… not really…
Installed both latest video drivers and rebooted.
Took 15 minutes to load Rhino… Got to this point after about a minute, and then was like this for 15 minutes, then it loaded fairly normally.
At points, it seemed to hang windows as well, with 0% cpu on everything, then recovered.

Rhino 6 SR23 2020-2-24 (Rhino 6, 6.23.20055.13111, Git hash:master @ 8106edaa648ba209a8fc587f0f7fcccbaac09169)
License type: Commercial, build 2020-02-24
License details: Cloud Zoo. In use by: nate (Living Design Studios Design Team)

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: LDSDRAFTING13

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA GeForce GTX 1060 6GB (NVidia) Memory: 6GB, Driver date: 1-29-2020 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 442.19

Secondary graphics devices.
Intel® HD Graphics 630 (Intel) Memory: 1GB, Driver date: 2-5-2020 (M-D-Y).

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 1-29-2020
Driver Version: 26.21.14.4219
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 6 GB

How many monitors are you running and at what resolution?

2 @ 1920x1080
both plugged into the Nvidia

this time, once one instance of Rhino is loaded, additional ones load normally, which wasn’t the case before

You don’t really have enough VRAM to be running two monitors.
As a test, disconnect one, restart and see if Rhino comes up more quickly.
If it does, then add the second monitor and see if the slow comes back.

OK, unplugged one, Rhino started quickly.
Plugged the 2nd one back in, no change… starts normally…

How much VRAM is recommended for 2 monitors? I’ve been running this setup for quite a while, and have not had any real issues with it…

A minimum of 4GB for each standard resolution monitor, and 8 GB for each high resolution monitor.
This is a V6 recomendation.
V6 used a much lower OpenGL standard.

Any chance there’s an option for increasing the VRAM on your GeForce?

Nope, i think I’d have to get a new card…

I rebooted, and it’s loading normally now with both monitors on.

Dunno, I ran two HD (1920 x 1080) monitors on a video card that had only 3Gb (GTX 780) with no problems with V6 at all. Currently running those two on a 980 Ti with 6Gb, no problems either. I also have a HD laptop with 2Gb that runs one screen just fine.

I suspect performance has a lot to do with how display is managed in a low VRAM situation.
Disconnecting an extra monitor on a specific system is still a pretty good test.