Rhino takes approximately 2 minutes to start

rhino5
unhandled

(D Malizia) #1

Good morning,

in the last few days my Rhino5 takes a lot to start (up to 2 minutes, depending on how many files are already open too).
I tried to follow this discussion as well:

Rhino 64bit takes AGES to start

I tried to launch Rhino in Safe Mode and I get the following message:

"_Rhino was started in Safe Mode and is being asked to automatically load this plug-in.

File: c:\Program Files\Rhinoceros 5 (64-bit)\Plug-ins\Toolbars.rhp

Sometimes bugs in plug-ins can break Rhino. Do you want to load this plug-in?

Click yes to load the plug-in_"

So I think toolbar plug-in can eventually be the problem.

I also ran the so called " testEnableDebugLogging" and I got a .txt file called “RhinoDebugMessages” that is the following one:

RhinoDebugMessages.txt (12.0 KB)

Could you please take a look at it? Probably the error is reported in it. If not, do you any suggestion how to solve this issue?

Thank you very much for your help and have you all a nice day


#2

Well, looking at the time stamps in the log, I would say the toolbars are not the problem, it looks like it’s having a problem seeing if the license is valid… Note the 1minute 40 second delay in the image below and the operation that in progress has something to do with the license…

But that’s about as much as I can tell you, not sure my theory is correct though, @brian can probably tell you more…


(Brian Gillespie) #3

Hi @d.malizia

I have seen Rhino 5 get slower and slower over time, but have never been able to figure out why. I have seen some people speed up startup by getting rid of a bunch of their custom settings. Here’s something to try (you can put your settings back if this doesn’t help):

  1. Close all copies of Rhino 5
  2. Open the Registry Editor (In Windows, click Start, then type RegEdit and press Enter)
  3. Browse to HKEY_CURRENT_USER\Software\McNeel\Rhinoceros\
  4. Rename the 5.0x64 key to --5.0x64 (the new name isn’t important, renaming it just makes it so Rhino can’t see it)
  5. Start Rhino

If Rhino starts faster, we can explore what other things might be going on. If not, please:

  1. Delete the newly created 5.0x64 key
  2. Rename --5.0x64 back to 5.0x64

Did any of that help?


(D Malizia) #4

Good morning and thank you so much for your support @Helvetosaur @brian

Unfortunately the Registry Edit trick did not work.
What I forgot to mention yesterday is that this behavior came up more or less one week ago, could it be linked to any Windows Update? I can not say exactly which day Rhino began to startup so slowly, but it happened suddenly, from one day to another.

Another remarkable thing I noticed a few minutes ago is that even if Rhino runs smoothly during design/modeling, it takes ages if I click on Help/about Rhinoceros. Does this corroborate @Helvetosaur theory? Can it be an internet connection problem that slows down the license verification?

Thank you again for your ideas, I hope we will find a way to get rid of it.


(David Eränen) #5

Hi @d.malizia,

It does sound like network connections are slow on your computer. Help/About connects to the internet, so that’s probably why they are slow.

Are you using any kind of anti-virus or firewall software? Those might be the ones slowing the connections.


(D Malizia) #6

Hello @DavidEranen, thanks for your reply.

Well, I am not using any specific anti-virus or firewall software except for the usual Windows pre-installed ones. I tried to turn Windows Firewall off and trigger Rhino again but sadly there is no remarkable difference in startup speed.


(David Eränen) #7

@d.malizia,

Could you try to start the Windows Command Prompt and type ping zoo.mcneel.com. What output do you get?


(D Malizia) #8

Hi @DavidEranen,

Output is: “Ping request could not find host zoo.mcneel.com. Please check the name and try again”

Thanks for your support


(David Eränen) #9

Okay - I’m afraid I can’t help you any further. We will have to wait for @brian to get back.


(Brian Gillespie) #11

I like where @DavidEranen is headed with this. Can you try disconnecting from your wired and wireless networks and report back if Rhino starts more quickly?


(D Malizia) #12

Hello @brian and thanks again for replying.

Well, apparently Rhino opens a bit faster while the laptop is unplugged from LAN cable and wi-fi receiver is off. Still a bit longer than I was used to but it must be due to an initial searching of any network connection.

Sadly we have to come to the conclusion that is just an internet connection problem so nothing I can really solve by myself. It´s weird that is not happening to my colleagues working next to me though.

Thank you all very much for your kind help and I wish you a good day


(Trevisan) #13

Hello,

i’m facing the same problem.

When I start Rhino, it takes more or less 2 minute to start,
while if i try without being connected to the net, it start immediately.

What else could i check?


(D Malizia) #15

Hello @LucaCIM ,

honestly I think it was just a Windows update problem.
A couple of weeks ago an automatic update has been installed on my machine and ever since Rhino starts normally as it was before.

Of course I have no proof of that, but the problem started after a Windows update and stopped after the following update.

Which Windows version do you have?
Did you try to boot Windows Update to check if there is any important update to run?

Have a nice day


(Trevisan) #16

really strange,
i’m running win10 pro. I also checked antivirus (eset) settings but i use this antiv software from more than 1 year and before never had this kind of problems.

It also happen that if i open scrolldown menu Help->Info on Rhino-> it freeze for some minute untill it get connected to retrive infos.

So i think it’s absolutely something related to the net connection, but only on this computer, because in my office there are at least other 5 people with same exact configuration OS/Rhino/antivirus and they don’t have any issue.


(D Malizia) #17

It was exactly the same for me @LucaCIM

All the other components of the team were using the same settings and I was the only one with this problem. And the same happened when I wanted to see the Rhino news under Help->About Rhinoceros (actually it was not even loading the “tips” part, only the “news” one on top).

We are running Windows 7 on our laptops but I guess this does not make any difference at this point.
I guess Windows will solve the problem by itself, but it will need some time.

Good luck!