Rhino startup script triggers too late when opening Grasshopper file


I have created a startup script for Rhino that runs a .bat file. (File>Properties>RhinoScript)
The .bat file moves some folders and files to the Grasshopper libraries folder:

The reason for this is, that I could more easily manage and update Grasshopper plugins for several users.

This works great when first opening Rhino and then the actual Grasshopper file(files to the libraries folders are moved before opening Grasshopper).

BUT when opening the Grasshopper file, the libraries files are not copied to the Grasshopper libraries folder before Grasshopper launches and I get the Unrecognized Objects window…


Does anyone have a workaround for this solution, so that I can launch my Grasshopper file and having Grasshopper library files copied before Grasshopper starts?

Or in general some good insights for setting up GH/Rhino settings for multiple users?

B r, Kristoffer

1 Like

Figured it out…

Instead of running the script from File>Properties>RhinoScript,
I run it from File>Properties>General

Now it works when opening a Rhino file and when opening a Grasshopper file.


1 Like