Rhino started behaving oddly

Using Rhino to model normally.
… Then unexpectedly when opening the ‘grid floor’ went missing and the central axes…
Restarting computer / rhino hasn’t helped. I have had to open an old model delete it and work from there.
Now it will only let me select ‘curve segment’ rather than the curve itself.
Then the ‘pop-up menu’ disappeared… it re-appears if I open the ‘default’ template, but then I lose the ‘Grid floor’… if I open model with the grid floor, the pop-up menu disappears

I really don’t want to reset rhino completely - it took me a long time to get the pop-up menu where i wanted it and to have a handful of custom commands set-up

Is there anything else I can do ?

Edit : ret-started another 4 times… and back up and running - although issue with missing ‘grid floor’ still remains in template:

This is what I am referring too… sorry couldn’t find correct terminology


How do I reinstate - have checked all options I can find which relate

Hi @ambrose_bill ,

The Grid settings are part of the document properties in Options > Doc Props > Grid. These work in conjunction with the active display mode settings via the Display panel. So if the display mode is set to not show the grid it won’t be seen. The document properties are file specific but the display mode settings are global and will impact all files. Check both and if the doc props were the issue, change them and use SaveAsTemplate to overwrite your starting template file with the change.

It also sounds like you may have sub-objects enabled in the Selection Filters. Make sure that is unchecked if you want to select an entire curve.

Regarding the pop up menu, I think you mean the middle mouse button action. If so, check Options > Rhino Options > Mouse for the setting. This is a global option and will affect all documents.

I hope that helps.

1 Like

Thanks Brian,
Really appreciate such a quick response…
re : the pop-up menu… this does seem to ocassionally ‘fail to load’ for want of a better description… but a restart or 2 usually reinstates (as it did in this instance)

Re : the grid… here’s the options I have ticked, and a screenshot to demonstrate that it’s just not visible ?

Thanks for the explanation re : sub objects… I can only assume i inadvertently invoked - as i don’t use the functionality i wasn’t used to it. Thanks for the heads up

Hi @ambrose_bill ,

Is the pop-up menu you’re referring to the middle mouse button action or another context menu that appears during some process? I’m not sure why that setting would not be seen on each start but Rhino for Windows will override the global settings which that is a part of with the last Rhino session closed. So perhaps the last one closed had a different setting chosen for the MMB.

Did you check your Display Mode settings for the active mode to see if the Grid is disabled for that display mode? Use the Display panel from the Window menu > Panels if you don’t see your Display panel.

ah yes of course. sorry it is the ‘pop-up default’ which i have assigned to my ‘3rd’ mouse button on the connexion mouse i use. It has just occurred to me that the issue may relate to the driver for the Connexion mouse, rather than Rhino.

I have ‘remade’ my template file and the issue with the world axes / grid is now resolved also. Presumably the template file got corrupted in some way.
So 100% resolution. Thanks for your help

1 Like